Temat: 130XE, które nie lubi SIO2SD

Sprawa jest dość dziwna jak dla mnie i jej zupełnie nie rozumiem, dlatego wybaczcie może miejscami chaotyczny opis.

Mam 130XE. Do ubiegłego tygodnia sprawowało się bez zarzutu. Aż do czasu, gdy zaczęło się foszyć na SIO2SD. Po prostu ich nie widzi. I to obowiązuje w obie strony. Bardzo ważną rzeczą na pewno to, że komputer bez problemu pracuje ze standardowymi stacjami dyskietek (LDW2000 i 1050, również w trybie turbo - Toms w LDW). Same SIO2SD (w liczbie 3, różne modele) nadal działają poprawnie i bez żadnego zgrzytu w innych Atarkach (przypomnę, że jeszcze niedawno działały również na tym kompie).

Jeśli chodzi o kierunek komputer->SIO2SD, to po prostu ani nie można zabootować z tego urządzenia, wgrać konfiguratora czy inne tego typu podobne. Również jeśli wgram sam konfigurator inaczej niż ze SIO2SD (z Uno Carta), to konfigurator raportuje brak urządzenia na szynie SIO. W przypadku jego poprawnej pracy można było normalnie wybierać pliki.

Jeśli chodzi o kierunek SIO2SD->komputer, to podczas normalnej pracy, nawet jeśli nie używam dysku SIO2SD (np. D0: jest wyłączony a jego rolę pełni fizyczna stacja), na jego ekranie wyświetlane są informacje o numerze używanego urządzenia i numerze wczytywanego sektora (np. jeśli czytam ze stacji dyskietek). W tym przypadku SIO2SD zachowuje się tak, jakby jedynie miało prąd, a nie widzi żadnych danych przesyłanych po szynie - głuche i ślepe.

Komputer ma usunięte wszystkie kondensatory wokół gniazda SIO (miał tak już jak go nabyłem).

Czy ktoś spotkał się może z takim zachowaniem? Jakby wcale nie działało to bym rozumiał. Ale skoro stacja dyskietek nie ma problemów to o co chodzi? Może któryś z forumowych magików dysponujący SIO2SD podjąłby się próby diagnozy i naprawy? Szkoda, żeby komputer leżał w szafie (bo tam trafił w tej chwili).

2

Odp: 130XE, które nie lubi SIO2SD

O ile pamiętam - dioda zenera na którymś pinie SIO załatwia sprawę, normalny objaw. Może być zainstalowana w atarce jak i w samym SIO2SD.

Sikor umarł...

3

Odp: 130XE, które nie lubi SIO2SD

Miałem kiedyś podobny przypadek, ale chodziło o magnetofon - działał bez zarzutów, natomiast SIO2SD nie. Po wymianie POKEY'a wszystko wróciło do normy.

Falcon030 14MB + CT60; Jaguar + Skunkboard; 65XE + SIO2SD + Ultimate + Stereo + VideoMod; 520STE + 4MB + Ultrasatan + HxC Emulator;  LYNX II + VGA Mod; A2600 + MultiCart; ZX Spectrum 128k +2 + PiocDivSD;  Amiga 600 + 2MB chip + Furia + SD;  C64 "chlebak" + 1541 Ultimate

4

Odp: 130XE, które nie lubi SIO2SD

Magnetofon działa poprawnie. Niestety, nie mam pokeya na podmianę bo w drugiej jednostce jest wlutowany w płytę (w tej też jest) :-/
Diodę mogę przylutować. Mogę poprosić o jakiś namiar? Natomiast dziwne jest to, że działało i przestało. Czyli raczej coś siadło (POKEY?) niż potrzebna jest łata. Nie powiem, żeby mnie to cieszyło :-/

5

Odp: 130XE, które nie lubi SIO2SD

http://atariki.krap.pl/index.php/SIO2SD - oczywiście się rąbnąłem, Dioda Schottkiego

Sikor umarł...

6

Odp: 130XE, które nie lubi SIO2SD

Dzięki. Tylko nie ma tam info, gdzie tą diodę należy wlutować.

7

Odp: 130XE, które nie lubi SIO2SD

http://www.atari.org.pl/forum/viewtopic.php?id=5208 - dioda na lini SIO3.

Sikor umarł...

8

Odp: 130XE, które nie lubi SIO2SD

Najwyraźniej głupi jestem, bo czytam, widzę, ale nie rozumiem, jak konkretnie tę diodę należy wlutować. Hasło "Dioda na linii SIO3" nic mi nie mówi :-(

9

Odp: 130XE, które nie lubi SIO2SD

Tak ciężko przejrzeć wątek i kliknąć w linki tam? http://atariki.krap.pl/index.php/SIO2PC - tu masz schemat podłączenia diody, wpinasz w Atarkę/wtyczkę/sio2COŚ, możesz wpiąć w każde urządzenie lub na początku łańcucha. Bosz, gorzej niż z dzieckiem (to był sarkazm), elektronikiem nie jestem, a znaleźć prosto, tylko się trzeba deko przekopać...
Anyway - powodzenia.

Sikor umarł...

10

Odp: 130XE, które nie lubi SIO2SD

Dioda jest niezbędna gdy do linii są podpięte więcej niż dwa urządzenia, a jedno z nich ma wyjście totem pole (TP). Dioda powinna być wstawiona w to urządzenie kreską do jego wyjścia, a drugi jej koniec traktujemy jako wyjście tego urządzenia. WSZYSTKIE urządzenia dołączane razem do komputera przez SIO MUSZĄ mieć wyjście open collector(OC). Dioda ma za zadanie przekształcić wyjście  TP (np. 74LS00, 74LS08) w wyjście OC (np. 7406, 7438 itp). Zapobiega to przeciążeniu wyjścia TP w stanie wysokim, gdy inne urządzenie OC wystawi stan niski na tej linii, bo dioda jest wtedy spolaryzowana zaporowo.
Przykładowo na stronie http://www.eurotronik.pl/pages/sio2sd.php?m2=103 widać, że tylko wersja 2 SIO2SD ma taką diodę.

Nikt nam lekkiego życia nie obiecał i słowa dotrzymał.
8bitów ; dereatari
Apple Hadware

11

Odp: 130XE, które nie lubi SIO2SD

Dzięki. Ale wnioskuję, że jeśli działało i przestało na tym kompie a nadal działa na innym oraz dotyczy to wszystkich trzech sztuk SIO2SD, które sprawdzałem, to nie jest to kwestia diody w SIO2SD a raczej uszkodzeniu uległo coś w komputerze. Mam racje? Bo dzieje się tak bez względu na to, czy podłączam SIO2SD bezpośrednio jako jedyne urządzenie, czy wpinam je w magistralę.
Chyba będę musiał wylutować Pokey i sprawdzić, czy jego wymiana nie poprawi sytuacji (jak radził rj1307).

12

Odp: 130XE, które nie lubi SIO2SD

Bywa różnie. W każdym razie powodzenia i daj znać, co było przyczyną.

Sikor umarł...

13

Odp: 130XE, które nie lubi SIO2SD

kondesatory na liniach sio..do wywalenia/weymiany

serdecznie proszę o maile na lotharek@lotharek.pl z tematem ATARIAREA - inne formy komunikacji zawodzą...
"The worth of all people is dependent on how they spend their life making contributions" - Kano Jigoro
FKMC /Fan Klub Malej Czarnej/   @Grey