51

Odp: c't IDE

lopez napisał/a:

Mam czysto teoretyczne pytanie, czy gdyby podłączyć przełącznik do ROM2 oraz zostawić kości na płycie oraz w C't to była by możliwość wyboru TOS'u ?

Problem w tym, że stare kości trzeba usunąć.

Było miło :) Do widzenia.

52

Odp: c't IDE

niech mi ktoś powie czy i gdzie można nabyć c't IDE...?

53

Odp: c't IDE

Pytaj kolegi artik-wroc, on to pobudował był.

54

Odp: c't IDE

Też bym przytulił do Mega ST1

Ostatnio edytowany przez PrzemasIII (2019-03-05 17:29:27)

800XL Side2,u1mb, Sdrive Max;STe;MST1;MSTe,HD50MB,Netusbee;MSTe;Falcon14MB;

55

Odp: c't IDE

artik-wroc napisał/a:

...gdyby ktoś reflektował to proszę o info w tym wątku.

Pytałem na starcie, teraz już wszystko wyszło i nie będzie więcej.

Było miło :) Do widzenia.

56

Odp: c't IDE

Trudno, pozostaje jeszcze czekać na TF540

800XL Side2,u1mb, Sdrive Max;STe;MST1;MSTe,HD50MB,Netusbee;MSTe;Falcon14MB;

57

Odp: c't IDE

Dzisiaj zabrałem się za montaż, wylutowałem CPU z płyty, wlutowałem podstawkę precyzyjną, jednak podczas próby wsadzenia CPU do c't pojawił się problem. Gdy w podstawkach są kości TOS to nóżki CPU są za krótkie aby go wsadzić w podstawę sad
Ten problem obszedłem dodając listwy żeńskie aby podnieść CPU i udało mi się zamontować CPU w c't.

Podobny problem mam podczas montażu c't na płycie, ponieważ interface zahacza o kondensator C105, myślałem aby to rozwiązać podobnie jak w problemie nr. 1 czyli dać drugą podstawkę bądź listwy precyzyjne aby podnieść całość, jednak wówczas nie da się złożyć komputera bo kanapka jest za wysoka.

Co zrobiliście z tym kondensatorem?

Montaż robię na płycie 520ST rev. H. (krótkie ST)

Post's attachments

c105.jpg 359.13 kb, nikt jeszcze nie pobierał tego pliku. 

cpu.jpg 273.51 kb, nikt jeszcze nie pobierał tego pliku. 

Tylko zalogowani mogą pobierać załączniki.

58

Odp: c't IDE

Co do "za krótkich nóżek procesora", to przecież na zdjęciu w pierwszym poście tego wątku masz pokazane, że można dać listwy żeby podnieść proca.
Jeśli chodzi o kondensator, to wylutuj go z płyty i umieść na leżąco (zostaw dłuższe nogi nowemu kondensatorowi, albo dolutuj kawałek drutu do tych istniejących, bo będą za krótkie na pewno, żeby go położyć).

A w ogóle, to pisałem również o innej metodzie, którą zastosowałem u siebie: nie wylutowałem procesora z płyty, tylko nalutowałem na niego listwy precyzyjne żeńskie i tak wsadziłem c't IDE. Plusy są takie, że jest mniej listew i mniej połączeń, kondensator wspomniany nie przeszkadza, jest łatwy dostęp do kości TOS-u, z którymi sobie sporo kombinuję.

Edit: nie mogę znaleźć gdzie pisałem o metodzie nalutowania na procesor... Możliwe, że pisałem to komuś w prywatnej korespondencji, lub w innym wątku, nie pamiętam. Załączam zdjęcie jak to zrobiłem u siebie.

Ostatnio edytowany przez Mq (2019-03-10 14:57:19)

Post's attachments

20190310_145226.jpg 158.18 kb, nikt jeszcze nie pobierał tego pliku. 

Tylko zalogowani mogą pobierać załączniki.

59

Odp: c't IDE

Walczę z uruchomieniem c't IDE i mam parę spostrzeżeń i problemów, może ktoś już je przerabiał smile

Uruchamiam interface z adapterem na kartę SD + przejściówka 40 na 44 pin, karty SD 2GB, 16GB i 32GB bo takie mam w domu, wszystkie kingstony.

1) sterownik ICD tak jak pisał Artik nie działa, cały czas twierdzi, że nie jest zainstalowany - sterownik odpada całkowicie.

2) sterownik HDDRIVER 7.51 działa, tworzy partycje, boot działa bez problemów - oczywiście brak kompatybilności z FAT16.

3) obraz Artika (http://atari.wroclaw.pl/pliki/ctide/obraz/) wrzucony na kartę SD działa bezproblemu

4) nie mogę za nic odpalić obrazu Putnika (http://8bitchip.info/atari/DiskImgPP1.html) wrzuconego na kartę SD, komputer nie widzi w tym wypadku dysku, chociaż jak mam w stacji sterownik hddriver to pokazuje, że widzi partycję C.
Obraz wrzucałem przy użyciu polecenia DD z linuxa, ale próbowałem też użyć programu Drive Image Putnika (http://atari.8bitchip.info/drimus.php).

Czyżby sterownik Putnika nie działał z adapterami na karty SD?

Post's attachments

ctide.jpg 73.78 kb, nikt jeszcze nie pobierał tego pliku. 

Tylko zalogowani mogą pobierać załączniki.

60

Odp: c't IDE

Pamiętaj, że dla interfejsu IDE musisz podmienić początkową część obrazu stosownym plikiem. Główny plik BIN ma autoboot dla ACSI. Putnik stosuje bardzo dziwny opis partycji w tym obrazie. Niby jest to FAT16 i PC/Windows widzi partycje i dane nich na tym obrazie (1 x podstawowa, 1 x rozszerzona z dwoma dyskami logicznymi) ale już żaden program do partycjonowania ani nawet DMDE nie rozpoznaje prawidłowo typu tych partycji.

Tu masz gotowy obraz:
https://we.tl/t-OofarNMBXH (link wygaśnie za 7 dni)

Ostatnio edytowany przez _tzok_ (2019-03-12 22:55:34)

Atari 1040STe (TOS 1.62/2.06 UK, 4MB RAM), Atari 1040STfm (TOS 1.04 UK, 1MB RAM, BLiTTER, Gotek FF)
Digital Data Deicke HD64 (Megafile 60), SF314, UltraSatan, Gotek HxC, NetUSBee
Atari 65XE (64kB), Atari 800XL (64kB), Sinclair SPECTRUM+ (48kB), TIMEX Computer 2048 (48kB)

61

Odp: c't IDE

Przede wszystkim obraz Putnika nie ma zainstalowanego drivera do IDE, więc trzeba by na karcie, na której wrzucimy ten obraz doinstalować jeszcze driver, który najpierw w tym celu by trzeba odpalić z dyskietki. Albo jak napisał _tzok_ zrobić podmiankę nagłówka z tego małego pliku od Putnika, ale tego nie robiłem, więc nie pomogę, pamiętam tylko, że widziałem gdzieś opis Putnika w tej sprawie...

62

Odp: c't IDE

Testowałem na Hatari, podmieniłem początek obrazu zgodnie z instrukcją, jednak nie startuje, to samo jest z plikiem który udostępnił _tzok_, sprawdzę jeszcze dzisiaj na prawdziwym sprzęcie. Może po prostu Hatari sobie nie radzi z IDE.

63

Odp: c't IDE

Wiesz co, ja powiem tak: powoli zaczynam coraz mniej używać Hatari. Na Hatari nie działa cała masa rzeczy. Może ktoś lubi to czy tamto, ale u mnie dużo lepiej sprawdza się stary dobry Steam. Niestety w kwestii interfejsu IDE trzeba się tym bawić na prawdziwym sprzęcie, bo żaden emulator nie wspiera bezpośrednio dostępu do dysku tak jak w przypadku Amigi robi to UAE. Jak robiłem kartę CF do Amigi kiedyś, to po prostu pod UAE podłączyłem ją, zainstalowałem system, wszystko sobie poustawiałem, a po przełożeniu karty do prawdziwej Amigi wszystko od razu po prostu działało idealnie. Szkoda, że dla Atari nie mamy tak dobrego softu, bo ja jestem starym Atarowcem i Amiga raczej średnio mnie bawi, lecz zazdroszczę im takich rozwiązań.
Wracając do tematu, mi się nie udało zrobić obrazu, który by działał i w Hatari i na prawdziwym sprzęcie. Obrazy działające na prawdziwym sprzęcie nie działają mi nijak w Hatari i odwrotnie. Oglądałem sobie pliki obrazów z Hatari i prawdziwego Atari, nagłówki są zupełnie inne, pliki różnią się diametralnie, próbowałem różnych opcji w Hatari i generalnie jest do d... z tym.
Ostatecznie jak się instaluje wszystko na prawdziwym sprzęcie to działa bez problemów.

64

Odp: c't IDE

No właśnie na Amidze robiłem tak jak ty i stąd moje próby na emulatorze smile

65

Odp: c't IDE

Podłączyłem rzeczony interfejs do złącza MegaBus w MegaST i zonk. TOS się zgłasza, ale dysku nie widać. Sprawdziłem miernikiem, wszystkie sygnały są. Jakieś pomysły dlaczego ?

EDIT: Gdy jest EmuTOS dysku nie widać po pojawieniu się pulpitu, przy zainstalowanym na karcie TOS ładuje się HDDriver wykrywa dysk i cztery bombki.

Ostatnio edytowany przez artik-wroc (2019-03-13 14:03:06)

Było miło :) Do widzenia.

66

Odp: c't IDE

No i okazało się, że Hatari nie lubi się ze sterownikiem IDE Putnika i z nim nie współpracuje, co mnie bardzo zmyliło.

Adapter SD, działa bezproblemowo z obrazem Putnika jednak trzeba wrzucić ten jego sterownik na początek obrazu.

ps. zasilanie dla adaptera SD, można pociągnąć z punktu który wcześniej wskazał Mq + masa z 40 pinu IDE.

67

Odp: c't IDE

A teraz coś dla tych co nie lubią kombinować opiszę jak szybko i sprawnie przygotować kartę SD dla IDE, a nie ukrywam, żę Mq mocno mi pomagał w ogarnięciu co i jak, za co mu dziękuję smile.

A w końcu udało mi się osiągnąć cel w zupełnie inny sposób wink

1) Ściągamy sterowniki ze strony http://atari.8bitchip.info/IDEDUD91.ZIP
2) na karcie SD tworzymy partycje FAT16, za pomocą np. programu Gparted, przy czym:
- pierwsza partycja nie może być większa niż 1 GB
- każda kolejna nie może być większa niż 2GB
- maksymalna ilość partycji to 14
3) na pierwszej partycji tworzymy folder AUTO i wrzucamy tam plik BIGDOS.PRG
4) na kolejnych wrzucamy sobie co chcemy, ja wrzuciłem gry, bo to mnie w sumie najbardziej interesowało
5) pozostałe pliki umieszczamy na dyskietce lub obrazie dyskietki dla goteka, tutaj przydaje się Hatari
6) uruchamiamy komputer i odpalamy program AUBDUD91.PRG i nacisakmy I jak install
7) po restarcie cieszymy się działającym dyskiem smile

Zapewne płatne drivery są lepsze/szybsze ale niestety drogie lub bardzo drogie smile

Chyba, że czegoś nie wiem i zaraz mi się coś posypie wink

ps. w dokumentacji coś wspominają o FAT32, ale jeszcze nie testowałem.

Ostatnio edytowany przez lopez (2019-03-13 20:40:41)

68

Odp: c't IDE

Płatne drivery od Putnika polegają na tym, że jemu płaci się raz, i dostajesz od niego driver do czego chcesz, bo on robi odrębne drivery do różnych urządzeń. Zaletą tego jest, że drivery Putnika nie są wielkim kombajnem obsługującym wszystko na raz, tylko driver jest bardzo malutki, więc mieści się w całości w bootsektorze i nie potrzebuje żadnych plików na dysku, oraz zajmuje bardzo mało pamięci. Natomiast drivery płatne nie mają żadnej dodatkowej funkcjonalności, nie są szybsze, i w ogóle się niczym nie różnią od tych udostępnionych za darmo. Po prostu Putnik kilka specyficznych driverów udostępnił za darmo, a z płatnymi to on najbardziej bazuje na UltraSatanach itp. które są najpopularniejsze i dlatego ludzie je kupują. Druga różnica polega na tym, że w komplecie z płatnym driverem dostajemy od Putnika jego program do partycjonowania.

A do czego ten BIGDOS skoro korzystamy z driverów od Putnika? Chyba że do tego, żeby było widać zwykłe partycje z normalnym FAT16, a nie z tym zmodyfikowanym przez Putnika? Tylko jeżeli tak jest, to obawiam się że odpalony BIGDOS może nam niepotrzebnie siedzieć w pamięci i czy to nie będzie robiło problemu z niektórymi grami? Tak mi przyszło to do głowy, bo testowałem dość dużo gier w adaptacjach HDD Putnika, i tam przy wielu z nich jest napisane, że dana gra działa przy danej ilości pamięci, ale pod warunkiem pamięciooszczędnego drivera do HDD. Nie wiem czy ma to jakiś związek wszystko, ale tak sygnalizuję...

Ostatnio edytowany przez Mq (2019-03-13 21:05:45)

69

Odp: c't IDE

No niestety to jest minus, ale według dokumentacji (dla tego sterownika) dla partycji powyżej 32MB BIGDOS jest wymagany.
Jak na razie testuję, odpaliłem kilka gierek. Po dłuższym czasie pewnie wyjdzie jeśli nie będzie coś działać.

70

Odp: c't IDE

Wiesz co, gry od Putnika już przy starcie pokazują zwykle jak jest coś nie tak z ilością pamięci, lub po prostu zazwyczaj wychodzą z gry z powrotem do GEM-a po planszy tytułowej z obrazkiem, tak że jeśli gra się już uruchomi, to będzie z nią raczej wszystko dobrze.

Z bigdosem doczytałem dokumentację od tego darmowego drivera PP, to jest faktycznie trochę inny sterownik. Z drugiej strony zaletą jest to, że można zwyczajne partycje FAT16 zrobić bez żadnych kombinacji sobie na pececie i już. No i całość jest darmowa, co zwłaszcza w przypadku HDDrivera zostawia nam w kieszeni pokaźną sumkę:-) Jeśli wszystko na tym będzie chodziło, to uważam, że jest to bardzo sensowne rozwiązanie. Napisz za jakiś dłuższy czas ewentualnie jak się to u Ciebie sprawuje.
Ewentualnie można podzielić kartę na więcej partycji, żeby miały poniżej 32MB i nie używać wtedy bigdosa. W dokumentacji stoi że partycji może być 14, to daje nam łącznie jakieś 440MB, więc kartę 512MB można tak sobie podzielić, resztę zostawić niepodzieloną i już. Z resztą jak kto woli.

Jeszcze co do prędkości. Putnik pisze, że na tym driverze przy prostej taśmie jest około 350kB/s. U mnie na płatnym sterowniku jest około 360kB/s, więc wychodzi na to, że jest to samo. Natomiast zastanawia mnie to co napisał o twisted cable. W zasadzie można by spróbować zrobić taką taśmę obróconą, bo to tylko taśma, a prędkość ponoć ma wzrosnąć do 1300kB/s, to chyba jest o co powalczyć.

Może sprawdź sobie jeszcze jaka jest teraz u Ciebie prędkość, na stronie Putnika jest również ten jego program do testowania prędkości.

Obecnie mam sprzęty poprzestawiane, nie mam trochę czasu zająć się ST, ale na pewno wypróbuję u siebie przy okazji twisted cable.

71

Odp: c't IDE

Więc prędkość na standardowej taśmie wynosi 364 KB/sec, więc jest podobnie jak u ciebie.
Jak uda mi się zdobyć drugą taśmę IDE ( bo mam tylko jedną i nie chce jej zepsuć wink ) to spróbuję zrobić ten przeplot, jak dobrze zrozumiałem to należy zamienić  przewody 0-7 i 8-15 miejscami i sprawdzę jeszcze raz.

Z problemów to nie wiem czy to normalne, ale odpalając np. Lotusa 3, podczas wczytywania gry rwie dźwięk i nie udało mi się odpalić Pricne of Persia.

72

Odp: c't IDE

Lotusa nie próbowałem akurat, ale rwanie dźwięku podczas wczytywania jest raczej normalne w niektórych grach, w kilku coś takiego trafiłem i wygląda mi na to, że to jest spowodowane przeróbką na wersję HDD gier, które grają jakąś muzykę normalnie w trakcie doczytywania z dyskietki.
Natomiast Prince of Persia u mnie działa normalnie. Przejrzyj na stronie Putnika, bo jest kilka wersji, pod różne maszyny, z różną ilością RAM-u i osobna wersja pod STE. Może używasz niewłaściwej? W którejś wersji jest kilka plików uruchomieniowych pod różne ilości pamięci, czytaj readme od Putnika w grach.
Na moim 520ST z 2,5MB a wcześniej z 1MB nie mogłem odpalić np. Monkey Island. W readme było coś napisane, że innym plikiem należy odpalić na Falconie i o dziwo u mnie właśnie działa ta gra z tego pliku.
Tak że trochę trzeba pokombinować czasem, ale generalnie na mnóstwo gier, które testowałem wszystkie mi się uruchomiły.
Ja miałem początkowo przy testach 1MB i na tym niektóre mi nie działały, ale jak rozbudowałem RAM do 2,5MB, to już chodzi wszystko bez problemu.
Jeszcze tak sobie myślę, że u siebie zarówno przy 1MB, jak i przy 2,5MB ja cały czas miałem i mam tak, że w banku 0 mam 512kB, a w banku 1 miałem też 512kB, a teraz mam tam 2MB. Tak czy siak u mnie zawsze oba banki były i są obsadzone, a u Ciebie jak pamiętam masz chyba 2MB tylko w banku 0, a bank 1 masz pusty - nie powinno mieć to chyba większego znaczenia, ale może w tym jest jakiś problem? Chociaż akurat Prince of Persia mi pamiętam że chodził kiedyś na pewno na STFM z 2MB, bo miałem takiego kompa, tyle że wtedy odpalałem to z dyskietek...

73

Odp: c't IDE

Nie ma ktoś zbędnego c't IDE albo płytki pod niego?

Atari 1040STe (TOS 1.62/2.06 UK, 4MB RAM), Atari 1040STfm (TOS 1.04 UK, 1MB RAM, BLiTTER, Gotek FF)
Digital Data Deicke HD64 (Megafile 60), SF314, UltraSatan, Gotek HxC, NetUSBee
Atari 65XE (64kB), Atari 800XL (64kB), Sinclair SPECTRUM+ (48kB), TIMEX Computer 2048 (48kB)

Odp: c't IDE

Lotus nie był przeznaczony do używania HDD, rwanie dźwięku i inne efekty specjalne są jak najbardziej spodziewane.

Atari: FireBee, (Falcon030 CT60e SuperVidel SvEthlana CTPCI), TT, (520ST Pak030 Frak PuPla Panther), (520ST 4MB ST RAM 8MB TT RAM CosmosEx SC1435), (1040STFM UltraSatan SM124), (1040STE 4MB ST RAM 8MB TT RAM CosmosEx NetUSBee SM144 SC1224), 260ST, 520 ST+, (MEGA ST SM125), (65XE Rapidus U1MB VBXE SIDE2 SIO2PC), (Jaguar SkunkBoard), Lynx II, 2x Portfolio

75

Odp: c't IDE

To ja się pochwalę, że tez mam zainstalowane, i wow, jakie to fajne smile
Mam jednak kilka pytań:
- Windows mi nie widzi karty CF od Artika. W jakim ona jest formacie? Jak wyświetlić i dodać zawartość. W jakimś emulatorze? Jak?
- Część gier nie chodzi, i chyba każda niewłaściwie wyświetla obrazek zaraz po starcie, dlaczego? 520 st, monitor sc1224 na niskiej rozdzielczości. Miałby ktos listę lub archiwum z rzeczami które chodzą bez problemów?

Atari Falcon 030 14MB, CF 8GB