26

Odp: Atari 130XE poziome pasy na ekranie

A mam proste pytanie - podłączałeś prrzez wyjście monitorowe (jeśli niedoczytałem to sorki)? Bo wyeliminujesz wtedy modultor. Sprawdź też na innym kanale (kanał 3 i bodajże 21) - zdarzały się "oporne" egzemplarze, jeśli idzie o modulator...

Sikor umarł...

27

Odp: Atari 130XE poziome pasy na ekranie

Na wyjściu monitorowym brak obrazu/sygnału na tv.
Sprawdziłem osyloskopem procesor i MMU i niestety zero reakcji.

28

Odp: Atari 130XE poziome pasy na ekranie

jer napisał/a:

Przy poniższych sprawdzeniach komputer ma być odłączony od zasilacza i monitora!
0. Czy jakiś układ w podstawce nie ma podwiniętego pina przy wkładaniu
1. czy piny od 3 do 7 i od 9 do 15 (bez 14) są we wszystkich pamięciach ze sobą zwarte (3 z 3, 4 z 4 itd)
2. Czy nie ma zwarć między sąsiadującymi pinami pamięci i fredka
3. Czy we wszystkich pamięciach pin 2 i 14 są ze sobą zwarte
4. Czy piny z punktu 3 są połączone z szyną danych (np. z pinami D0-D7 Basica lub OS ROM) przez oporniki 100 Ω
5. Czy piny D0 - D7 nie są zwarte do masy lub zasilania

Po włączeniu komputera:
6. Czy na pinie 2, a potem 37 Freddiego jest przebieg 14 MHz. (potrzebny oscyloskop big_smile )
7. Czy na szynach danych i adresowej są przebiegi

Potem już loteria, zacznij od MMU

AD 6. - na 37 pinie ok 3,5 MHz

29

Odp: Atari 130XE poziome pasy na ekranie

Freddie sprawdzony w innym Atari.
Jest ok.

30

Odp: Atari 130XE poziome pasy na ekranie

niepartyjny napisał/a:

Sprawdziłem osyloskopem procesor i MMU i niestety zero reakcji.

Dlaczego tylko na procesorze i MMU sprawdzałeś "reakcję"? Nie ma przebiegów adresowych i danych na ANTICu, GTIA, OS-ROM, Basic i pozostałych? Wszystko na 0 ?
Czy w gnieździe kartridża nie siedzi jakiś śmieć zwierający styki?
Czy jest !CAS, !RAS i !WE na pamięciach?
Czy RESET na pinie 40 i IRQ na pinie 4 procka są w stanie wysokim a na pinie 37 jest FI0?
Czy na pinach 16, 28 i 25 GTIA są jakieś przebiegi?

Ostatnio edytowany przez jer (2018-07-12 06:39:10)

Nikt nam lekkiego życia nie obiecał i słowa dotrzymał.
8bitów ; dereatari
Apple Hadware

31

Odp: Atari 130XE poziome pasy na ekranie

Procesor podmieniony,dalej no signal.
Jedna rzecz mnie dziwi.Zrobiłem pomiary oscyloskopem na testowym,sprawnym 800XE .Sonde ustawiłem na 50mV i sprawdziłem ram, Freddiego,procesor itp.Na oscyloskopie zobaczyłem poprawne wykresy.Na tych samych ustawieniach zacząłem sprawdzać uszkodzone 130 XE.I tu zaskoczenie:
Uzyskałem wykres tylko z Freddiego.
Ram,procesor i inne układy martwe.Zmieniłem ustawienia oscyloskopu z 50mV na 2mV i dopiero wtedy uzyskałem wykresy na ekranie oscyloskopu.

Tak,na pinach 16, 28 i 25 GTIA są przebiegi ale po zmniejszeniu napięcia na oscyloskopie z 50mV na 2mV.
Tak na pamięciach są sygnały Cas,Ras,We ale po zmniejszeniu napięcia na oscyloskopie z 50 do 2mV.Gniazdo carta czyste.

32

Odp: Atari 130XE poziome pasy na ekranie

Chyba mam... Napięcia na procesorze w uszkodzonym 130XE to:
Pin 40- 4,47V
Pin 4 tylko 0,23V
Pin 37 aż 4,42 V

W testowym 800 XE to:
Pin 40- 4,46V
Pin 4- 5,08V
Pin 37- 1,95V

33

Odp: Atari 130XE poziome pasy na ekranie

Rozumiem, że te ustawienia to 50 mV/dz(iałkę) i 2 mV/dz. Działka to ta kratka na ekranie oscyloskopu. Wychodzi na to, że oglądasz szumy a nie przebiegi. Przebiegi w komputerze powinny mieć amplitudę 3-5V, ustawienie powinno być 1V/dz. Jeden volt na działkę!
Sprawdź czy na płycie jest wmontowany opornik R22, bo IRQ masz 0. R22 to środkowy z trzech poziomych oporników 3k między ECI i gniazdem monitora. Jeśli jest to wymień Pokeya.

Ostatnio edytowany przez jer (2018-07-12 22:35:51)

Nikt nam lekkiego życia nie obiecał i słowa dotrzymał.
8bitów ; dereatari
Apple Hadware

34

Odp: Atari 130XE poziome pasy na ekranie

Opornik R22 zamontowany,Pokey wymieniony,był sprawny.
130-tka nadal martwa.

35

Odp: Atari 130XE poziome pasy na ekranie

To teraz trzeba wymieniać po kolei pozostałe układy. Jeżeli IRQ nadal jest zawsze w stanie niskim to zacznij od MMU, PIA i po kolei pozostałe. Ale przedtem chwyć lupę, ucinaczki i dokładnie obejrzyj płytę od spodu, może jakaś końcówka przywiera. Za długie przytnij.

Nikt nam lekkiego życia nie obiecał i słowa dotrzymał.
8bitów ; dereatari
Apple Hadware

36

Odp: Atari 130XE poziome pasy na ekranie

MMU podmienione,nadal martwa płyta.
Ale...Obejrzałem płytę w świetle dziennym.Znalazlem na spodzie płyty uszkodzoną ścieżkę i jedna zwartą końcówkę.Nadal nie odpaliła.
Jeszcze raz miernikiem sprawdziłem pamięci i niestety jest zwarcie pinów 2 i 14 do Basic i ROM.Np trzecia kostka licząc od góry z lewego i prawego rzędu , z pinu 2 ma zwarcie z Basic  na pinie 15 czyli D5 i zwarcie z ROM na pinie 17 czyli D5.
A tak jak pisałeś te połączenia powinny być przez opornik .
PIA podmienione nadal no signal.Na oporniku R22 na wejściu 5,10V na wyjściu 0,20V. IRQ na Pokey i PIA 0,20V
Ma ktoś na zbyciu małe MMU C025953?Nie mam na podmianę.

Ostatnio edytowany przez niepartyjny (2018-07-14 14:40:45)

37

Odp: Atari 130XE poziome pasy na ekranie

Niektóre wersje płyt nie miały tych oporników, były na krótko z danymi pozostałych układów. To np. płyty CA200519, CA20097 (65XEN), i XEGS. Ważne, żeby nie było zwarć między liniami danych i adresowymi.
Czy sygnał IRQ jest zawsze niski, po każdym włączeniu? Może ten opornik 3k jest odłączony od +5V lub pęknięty.

Nikt nam lekkiego życia nie obiecał i słowa dotrzymał.
8bitów ; dereatari
Apple Hadware

38

Odp: Atari 130XE poziome pasy na ekranie

Do opornika R22 dochodzi +5V.Nawet go wulutowałem i podmieniłem.Nadal na wyjściu 0,2V.
Zauważyłem jeszcze jedną rzecz.Po jakimś czasie nieużywania płyty , podpięciu do zasilania i włączeniu power na chwilę na pinie procesora nr 4 czyli IRQ  pojawia się 5V i po ok 20 sekundach spada do 0,2V.Wyłączam zasilanie i włączam ponownie i mam 0,2 V.Odpinam wtyczkę zasilania,odkładam płytę na jakiś czas podpinam i na moment jest +5V.Kondensatory?
No i nie wiem jak poradzić sobie ze zwarciem pomiędzy pin 2-14 kostek RAM z D0-D7 ROM I Basic.

Ostatnio edytowany przez niepartyjny (2018-07-14 20:26:43)

39

Odp: Atari 130XE poziome pasy na ekranie

Nie martw się zwarciem do OS i Basica. Tak ma być i tyle. Wymień Basic , OS ROM, potem TTL-e. Kolejność dowolna, i tak uszkodzony scalak wylutujesz na końcu, bo tak twierdzi niejaki Murphy.
Edit: i nie będziesz miał scalaka na wymianę, bo tak twierdzi...

Ostatnio edytowany przez jer (2018-07-14 22:54:11)

Nikt nam lekkiego życia nie obiecał i słowa dotrzymał.
8bitów ; dereatari
Apple Hadware