1

Temat: 600xl defekt, czerwono/brązowy ekran

Cześć, wpadł mi w ręce niesprawny 600xl bez zasilacza. Historia nieznana (pozatym, że nie działa,ale dioda się pali), był na pewno rozkręcany, bo nie ma kompletnie ekranów. Po gtia wnioskuję że to wersja PAL (C0148898-001). Płyta i kondensatory wyglądają ok. Sprawdziłem go z oryginalnym psu od 65xe (nie ten model zabijający wszystkie atarki). Był od początku brązowo-czerwony ekran, basic się nie odpala. Obraz mam wyjście video, kabel scart, monitor crt. Powyjmowałem romy i je podociskałem, wyczyściłem podstawki kontaktem U/S. Zainstalowałem upgrade ramu od Lotharka do 64kb (na Youtubach często przy czerwonym ekranie winą obarcza się albo wadliwy ram i/lub procek) - wywaliłem u11, u12(kości rom), u13(ic delay, powinien być niepotrzebny z modułem 64kib, moduł podpięty pod 16pin mmu CI (U2)). Podmieniłem jeszcze mmu i cpu z 65xe też bez jakichkolwiek zmian.
Sprawdziłem napięcie na mmu, pokeyu, anticu,gtia i jest w okolicach ~5,1v. Procek, gtia,antic się trochę grzeją, trochę u3/u4, nie wiem czy to normalne (aż prosi się o jakiś radiator).
Czy ktoś ma może pomysł co i jak sprawdzić, żeby ustalić źródło usterki? Nie mam niestety zapasowych romów basica, gtia i antica żeby sprawdzić czy ich podmiana coś da..
Niestety nie mam carta diagnostycznego, widziałem że Flashjazzcat używa jednego, ale z tego co widzę nie jest dostępny w sprzedaży.

Pozdrawiam,
P.

Ostatnio edytowany przez saulot (2021-03-11 01:47:56)

Post's attachments

600xlRedScreen.jpeg 125.61 kb, liczba pobrań: 43 (od 2021-03-11) 

Tylko zalogowani mogą pobierać załączniki.
saulot / [nokturnal]
==================================
wiki Atari 16/32 bit: https://bus-error.nokturnal.pl

2

Odp: 600xl defekt, czerwono/brązowy ekran

Należy sprawdzić delay line

3

Odp: 600xl defekt, czerwono/brązowy ekran

Możesz to jakoś rozwinąć, w sensie jak to najlepiej sprawdzić? Nowy SRAM teoretycznie zastępuje u13(ic delay module), który wyjąłem z podstawki.

saulot / [nokturnal]
==================================
wiki Atari 16/32 bit: https://bus-error.nokturnal.pl

4

Odp: 600xl defekt, czerwono/brązowy ekran

Jak włożyłeś sram to DL jest zbędna więc to nie to

5

Odp: 600xl defekt, czerwono/brązowy ekran

ROM znień

ADRES: pin@atari.pl - konto zlikwidowane. Aktualny adres: pin(at)atari8.info

6

Odp: 600xl defekt, czerwono/brązowy ekran

Niestety nie mam zamiennika, mam stary rom z 65xe, ale podstawka jest za mała więc chyba będę musiał zdobyć zamiennik albo wylutować podstawkę(ale nie jestem pewien czy te romy są kompatybilne). Ktoś tutaj na forum diluje takimi rzeczami?

saulot / [nokturnal]
==================================
wiki Atari 16/32 bit: https://bus-error.nokturnal.pl

7

Odp: 600xl defekt, czerwono/brązowy ekran

Tak jak Pin wspomniał, ja bym też obstawiał ROM. Ale możesz jeszcze coś sprawdzić: wyciągnij Basic i odpal bez niego, komputer bez Basica powinien się normalnie uruchomić, a jeśli Basic uszkodzony to też może dawać objawy jak przy uszkodzonej pamięci.

8

Odp: 600xl defekt, czerwono/brązowy ekran

wyjąłem rom z u4, potem jeszcze u3(systemowy) i jest to samo.

Ostatnio edytowany przez saulot (2021-03-11 17:02:28)

saulot / [nokturnal]
==================================
wiki Atari 16/32 bit: https://bus-error.nokturnal.pl

9

Odp: 600xl defekt, czerwono/brązowy ekran

Bez systemowego nie wstanie komputer. Pisałem tylko o Basicu, można go wyjąć i komputer powinien wtedy wstać.
Musisz wobec tego próbować podmienić OS ROM.

10

Odp: 600xl defekt, czerwono/brązowy ekran

Jasne, z wyjętym romem basica jest ten sam czerwony ekran.

saulot / [nokturnal]
==================================
wiki Atari 16/32 bit: https://bus-error.nokturnal.pl

11

Odp: 600xl defekt, czerwono/brązowy ekran

Czerwony/brązowy ekran to efekt braku odczytu ROMu, ale nie koniecznie sam ROM jest winny, jakikolwiek układ może blokować magistralę i też będzie taki efekt. ROMy są takie same w całej serii XL/XE, tylko w czasie produkcji XE "wyszły" im mask-ROMy z BASIC i zaczęli stosować EPROMy OTP, które mają więcej nóżek...

To jest fabryczny "mod" z 800XE:
https://obrazki.elektroda.pl/5472814500_1615492822_thumb.jpg

Ostatnio edytowany przez _tzok_ (2021-03-11 22:01:16)

Atari 1040STe (TOS 1.62/2.06 UK, 4MB RAM), Atari 1040STfm (TOS 1.04 UK, 4MB RAM, BLiTTER, Gotek HxC) + Digital Data Deicke HD64, SF314, UltraSatan, Gotek HxC, NetUSBee
Atari 800XE (SIMM EXP 1MB), Atari 800XL (RAMBO XL 256kB), Sinclair SPECTRUM+ (48kB), TIMEX Computer 2048 (48kB)
Commodore A600 (KS 1.3/3.1, 2MB CHIP RAM, 4MB FAST RAM, CF 4GB, Gotek FF)

12

Odp: 600xl defekt, czerwono/brązowy ekran

ok update. komp wstał. wylutowałem układy z 65xe i podmieniałem je po kolei, gtia i antic są ok. Uwalony był rom z osem(miałem jakiś nie używany z 65xe), ale basic też jest chyba walnięty .. smile dzięki za wskazówki!

Ostatnio edytowany przez saulot (2021-03-11 22:45:35)

Post's attachments

600xl_selftest.jpeg 169.68 kb, liczba pobrań: 14 (od 2021-03-11) 

Tylko zalogowani mogą pobierać załączniki.
saulot / [nokturnal]
==================================
wiki Atari 16/32 bit: https://bus-error.nokturnal.pl

13

Odp: 600xl defekt, czerwono/brązowy ekran

Nie wiem czy chcesz do tego komputera wsadzić oryginalny OS, czy niekoniecznie. Możesz użyć zwykły EPROM, czy tam EEPROM, tylko musisz go trochę "podrutować", bo oryginalnie jest maskrom, który ma inny układ wyprowadzeń i mniej nóżek. To najtańsze rozwiązanie, w dodatku możesz wsadzić wtedy np. jakiś przełącznik OS-ów przy okazji, albo coś w tym stylu.
Jeżeli natomiast miał byś chęć posiadać oryginalny OS w tym komputerze, to jak by co mam oryginalny OS ROM do Atari w dwóch wersjach do wyboru C061598B (czyli taki jak był w 800XL/65XE) oraz C300717-001A (czyli taki jak był w 130XE). Mogę sprzedać któryś z tych ROM-ów za 35zł plus 12zł przesyłka paczkomatem, jeśli był byś zainteresowany, to zapraszam na PW.

14

Odp: 600xl defekt, czerwono/brązowy ekran

Mq dzięki. Generalnie chcę tam wsadzić Ultimate'a, ale musiałem się upewnić, że komp w ogóle wstanie. Są jeszcze drobne problemiki, czasami self test się nie odpala, jest tylko czarny ekran, nie wiem czy to normalne.
Wsadziłem carta side2 i wygląda na to że coś tam działa.

Ostatnio edytowany przez saulot (2021-03-11 22:50:55)

saulot / [nokturnal]
==================================
wiki Atari 16/32 bit: https://bus-error.nokturnal.pl

15

Odp: 600xl defekt, czerwono/brązowy ekran

Spoko, tak tylko przy okazji zaproponowałem. Mam takie dwa maskromy sprawne na zbyciu, bo sam wymieniałem sobie OS na qmega w swoich komputerach.

Z tym selftestem, to niejest normalne. Ale jeśli dzieje się tak czasami tylko losowo, to może po prostu nie kontaktuje coś w podstawkach? Takie rzeczy trudno namierzyć, warto wszystko powyciągać i jeszcze raz powkładać.  Testy w wypadkach spontanicznych i niezbyt powtarzalnych problemów przeprowadzam też tak, że np, wyginam płytę delikatnie w różne strony na włączonym kompie i patrzę czy się wtedy nic nie dzieje. W taki sposób można znaleźć np. pęknięte ścieżki, albo zimne luty pod scalakami, albo pęknięte przelotki, albo skorodowane nóżki scalaków. Drugą metodą takich poszukiwań jaką stosuję jest zamrażanie fragmentów płyty i scalaków, również na włączonym komputerze. Jak są jakieś pęknięcia, to pod wpływem różnic temperatur wychodzą na jaw. Zamrażam poprzez oblewanie sprężonym powietrzem w płynie obróconym do góry nogami.

16

Odp: 600xl defekt, czerwono/brązowy ekran

Mam jeszcze jeden problem po boocie z option nie odpala się self test, mam nadzieję że to nie znajduje się w romie basica..

saulot / [nokturnal]
==================================
wiki Atari 16/32 bit: https://bus-error.nokturnal.pl

17

Odp: 600xl defekt, czerwono/brązowy ekran

Nie. Self test znajduje się w OS ROM. A jak odpalasz kompa normalnie do Basica, i wtedy z Basica włączysz selftest za pomocą komendy BYE (lub skrót B.), to odpala się zawsze dobrze? Bo może jest jakiś problem z klawiszami konsoli?

18

Odp: 600xl defekt, czerwono/brązowy ekran

rom basica jest padnięty, ale udało mi się z side2 odpalić. Chyba taśma klawiatury trochę nie kontaktuje, bo dioda power czasami się nie pali. Ale klawiatura wg testu jest ok.

Ostatnio edytowany przez saulot (2021-03-12 00:38:54)

saulot / [nokturnal]
==================================
wiki Atari 16/32 bit: https://bus-error.nokturnal.pl

19

Odp: 600xl defekt, czerwono/brązowy ekran

Mq napisał/a:

Możesz użyć zwykły EPROM, czy tam EEPROM, tylko musisz go trochę "podrutować", bo oryginalnie jest maskrom, który ma inny układ wyprowadzeń i mniej nóżek.

XL OS był zawsze w normalnym OTP EPROMie (27128) w obudowie DIP28, tylko BASIC był w MASK ROMie DIP24 (2364), ale niektóre płyty 600XL miały miejsce na EPROM DIP28 dla BASIC ROMu, np.:
https://oldcrap.org/2018/02/20/atari-60 … ousel-1426

Można użyć EPROMu 27C256 (bez przeróbek aktywna będzie jego "górna" połowa).

Za "odpalanie" SELF-TESTu odpowiada MMU (GAL16V8).

Ostatnio edytowany przez _tzok_ (2021-03-12 00:49:41)

Atari 1040STe (TOS 1.62/2.06 UK, 4MB RAM), Atari 1040STfm (TOS 1.04 UK, 4MB RAM, BLiTTER, Gotek HxC) + Digital Data Deicke HD64, SF314, UltraSatan, Gotek HxC, NetUSBee
Atari 800XE (SIMM EXP 1MB), Atari 800XL (RAMBO XL 256kB), Sinclair SPECTRUM+ (48kB), TIMEX Computer 2048 (48kB)
Commodore A600 (KS 1.3/3.1, 2MB CHIP RAM, 4MB FAST RAM, CF 4GB, Gotek FF)

20

Odp: 600xl defekt, czerwono/brązowy ekran

A, sorry, przepraszam za wprowadzenie w błąd. Mówimy o OS ROM, a ja myślałem o kości Basica. Oczywiście _tzok_ ma rację, pomieszałem różne waluty...

21

Odp: 600xl defekt, czerwono/brązowy ekran

Ok, to wyszło do tej pory, że przyczyną usterki był procesor Sally, padnięty rom systemowy oraz ROM basica. Przy dodatkowych testach wyszło, że GTIA też jest uszkodzone, bo sprajty w grach się dziwnie wyświetlały (niekompletne, wyglądało jak brak szczegółów na postaciach, były "blokowate").
Podmieniłem działający ROM z basica z 65xe (chyba był sprawny), ale komputer nie wstaje albo się wiesza na memory teście (przed wyświetleniem drugiego bloku ROM, który zwykle jest czerwony). Generalnie odpalałem trochę gier i na np. owca demo są problemy z wyświetlaniem grafiki, co n tą klatkę duża część lub całość obrazu wypełniają jakieś śmieci, część rzeczy wyświetla się poprawnie.

saulot / [nokturnal]
==================================
wiki Atari 16/32 bit: https://bus-error.nokturnal.pl

22

Odp: 600xl defekt, czerwono/brązowy ekran

No to może to nie wina głównych kości tylko logiki wspomagającej? Miesiąc temu naprawiałem 600XL, w którym walnięta była kość bodajże 74ls157.

Pamięć studenta ma charakter kwantowy - student wie wszystko, ale jednocześnie nic nie pamięta.
- Kilka(naście?) pudełek z klawiszami i światełkami. I jeden Vectrex, żeby nimi wszystkimi rządzić.

23

Odp: 600xl defekt, czerwono/brązowy ekran

Obstawiam, że saulot testuje wyciągane układy w drugim komputerze.

24

Odp: 600xl defekt, czerwono/brązowy ekran

Nie, testuję na tym samym. Działające układy wyciągnąłem z 65xe, który był sprawny, ale jest teraz w rozsypce, bo go doprowadzam do porządku...

saulot / [nokturnal]
==================================
wiki Atari 16/32 bit: https://bus-error.nokturnal.pl

25

Odp: 600xl defekt, czerwono/brązowy ekran

No to raczej testuje się w drugą stronę - nieznany na sprawnym.

Pamięć studenta ma charakter kwantowy - student wie wszystko, ale jednocześnie nic nie pamięta.
- Kilka(naście?) pudełek z klawiszami i światełkami. I jeden Vectrex, żeby nimi wszystkimi rządzić.