1

Temat: problem ze sprzętowym resetem na 74123

Jak oglądam na Youtube filmy Zaxona o SIDE to trochę mnie trzęsie przy okazji tego ciągłego pstrykania włącznikiem zasilania.
Przypomniało mi się, że gdzieś, kiedyś, w którejś gazecie był układ do zimnego resetu.
Bo z oczywistych przyczyn nie mogę w czasie używania SIC!a używać do resetowania przycisku na kartridżu Blizzarda (pomiędzy masą a 4 nogą 7400, dopisek: zwiera po prostu RD5 do masy).
Ten zimny reset to ftp://ftp.pigwa.net/stuff/mirror/www.at … /reset.htm
Złożyłem, zamontowałem. I okazało się, że jak to jest podpięte do RD5 (8-ma noga MMU) to SIC! nie działa.
Nie wiem jaki jest stan na RD5, niski czy wysoki, bo nie bardzo rozumiem jak działa ten 74123, czyli czy następuje to przełączenie banku pamięci $A000-$BFFF.

Ma któryś z Was ma może wiedzę, czy da się to jakoś poprawić, żeby SIC i prawdopodobnie inne kartridże działały i ten reset też był używalny?

Może podłączenie do RD5 tylko w czasie resetowania - podwójny przełącznik, dodatkowo w czasie łączenia Reset do masy łączyć układ do RD5?

Ostatnio edytowany przez lemiel (2011-07-23 22:08:11)

2

Odp: problem ze sprzętowym resetem na 74123

Podłącz ten układ do RD5 nie bezpośrednio, jak na rysunku, ale przez diodę (1N4148 lub podobną), katodą w stronę MMU.

Ceterum censeo Unionem Europaeam delendam esse.

3

Odp: problem ze sprzętowym resetem na 74123

Dzięki.
Ale nie działa z tą diodą.
Ogólnie, zauważyłem, że to tak jakby wcale nie działa ten reset.
Wylutowałem.
No chyba, że coś popsułem w kompie przez to lutowanie.
SIC! działa, ale Blizzard przestał - tyle, że on wiekowy, może coś mu się stało?

4

Odp: problem ze sprzętowym resetem na 74123

Z tego co sie Candle'a  kiedys pytalem to taki reset dzialac nie bedzie...
Lukales te rozwiazanie z podpieciem mikroswitcha na stronie :http://sic.pigwa.net/ "przydatne informacje" ?

"wszystko się kiedyś kończy......."

5

Odp: problem ze sprzętowym resetem na 74123

lemiel napisał/a:

Dzięki.
Ale nie działa z tą diodą.
Ogólnie, zauważyłem, że to tak jakby wcale nie działa ten reset.

Sprawdzałeś działanie z podłączonym kartridżem, czy bez?

Ceterum censeo Unionem Europaeam delendam esse.

6

Odp: problem ze sprzętowym resetem na 74123

Stryker: jeszcze nie, spróbuję w tygodniu.

Simius: i z kartridżem i bez niego. Może nie każdy kartridż dobrze się zachowuje?
Chodziło mi o sytuację, w której potrzebuję wyjść z programu odpornego na reset (np. US Copy 4). Nie było efektu.
Ten dodatkowy przycisk zachowywał się jak zwykły Reset.

Wychodzi mi na to, że pewnie jeszcze musi być ten sygnał dostępny, że ma się bootować z kartridża coś, a tu widocznie nie było tego efektu.
Nie próbowałem z inną zawartością flasha w SIC! niż SDX, a może to jej odpięcie przez cold /n spowodowało brak reakcji?

7

Odp: problem ze sprzętowym resetem na 74123

Ano, mnie tez trzesie, cold reset  juz od dawna mam zrobiony ,wystarczy ze wcisne shift i reset w atarce  i wychodzi ze wszystkiego resetoodpornego softu  .Gorzej z ponownym bootowaniem z carta .

Dwa korce ziemniaków, gęsich jajek kopa, żeby móc to połknąć, tęgiego trza chłopa. GG3456993

8

Odp: problem ze sprzętowym resetem na 74123

Mechanizm działania układu polega na wygenerowaniu przez ok. 0,6s stanu wysokiego na TRIG3. Kiedy procedura resetu wykryje zmianę stanu tej linii w stosunku do poprzedniego, zapisanego w GINTLK, wówczas następuje przejście do zimnego startu. Układ ma jednak pewne ograniczenia. Po pierwsze - nie będzie działał z kartridżem zajmującym obszar $A000...$BFFF. Ponieważ taki kartridż ustawia TRIG3 na stałe w stan wysoki (chyba, że potrafi sam się odłączyć, jak SDX). Po drugie - układ jest wyzwalany zboczem opadającym, więc o ile nie stanowi to problemu w komputerach serii XE, w których impuls reset jest wytwarzany przez uniwibrator NE555 w momencie zwolnienia przycisku RESET, jego długość jest z góry ustalona i nie zależy od czasu przyciśnięcia przycisku, o tyle w komputerach serii XL impuls reset trwa tyle, ile wciśnięty jest przycisk. Jeśli będzie wciśnięty zbyt długo, stan wysoki wygenerowany na TRIG3 w momencie przyciśnięcia skończy się zanim procedura reset go sprawdzi. I wtedy nie zadziała.

Ceterum censeo Unionem Europaeam delendam esse.

9

Odp: problem ze sprzętowym resetem na 74123

Zaxon a co to za układ? Czy tylko spaczowany OS jak tu: http://www.atariage.com/forums/topic/18 … -keycombi/ albo QMEG?
Możesz się pochwalić?

Simius: przyznaję nie rozumiem wszystkiego, ale z tego co zrozumiałem, to jeśli SIC! jest włączony (bo on pracuje w tym zakresie właśnie), to nie będzie działało, chyba, że SDX go odłączy.

W powyższym wątku jest też dodatek o zmianie wartości kondensatora na 33 albo 100 μF.

Jeszcze spróbuję się z tym pobawić, w końcu to tylko 4 kabelki to przylutowania (chociaż skręciłem już obudowę). Dolutuję jeszcze przełączniki do włączenia bezpośrednio i przez diodę układu do MMU, żeby posprawdzać więcej.

10

Odp: problem ze sprzętowym resetem na 74123

lemiel, widzę na liście, że zamówiłeś sobie IDE Plusa... a w takim układzie ten zimny reset wkrótce przestanie Ci być potrzebny.

KMK
? HEX$(6670358)

11

Odp: problem ze sprzętowym resetem na 74123

lemiel napisał/a:

Przypomniało mi się, że gdzieś, kiedyś, w którejś gazecie był układ do zimnego resetu.

Bajtek, okolice 87-88 roku, tyle że to rozwiązanie dla "mydelniczki" było.

wszystkie trzy strony świata

12

Odp: problem ze sprzętowym resetem na 74123

drac030: coś o Shift+Reset gdzieś mi mignęło.
No to oby.

Lt_Bri: w pierwszym poście jest link.

13

Odp: problem ze sprzętowym resetem na 74123

Lemiel, mam spathowany rom z resetem i paroma innymi dodatkami,  poza tym filmiki sa robione na prototypie i wczesnych wersjach softu, w finalnej wersji nie bedzie potrzeby pstrykania wylacznikiem.

Dwa korce ziemniaków, gęsich jajek kopa, żeby móc to połknąć, tęgiego trza chłopa. GG3456993

14

Odp: problem ze sprzętowym resetem na 74123

Lamiel: http://sic.pigwa.net/screen/sic_reset_menu/

"wszystko się kiedyś kończy......."

15

Odp: problem ze sprzętowym resetem na 74123

Chłopaki wiem. Dzięki smile Spróbuję w następnych dniach.
Dziś próbowałem odpalić APE i ProSystem z SIO2USB z AtariMax i jest zabawnie, bo ProSystem nie widzi CA z Toms Turbo. Ale skopiowałem kilka dyskietek w trybie zwykłej CA.

W tym opisie pod zdjęciami brakuje dopisku, że w zaproponowanym układzie tę nogę do masy to lutujemy do nogi 10 U3 - naszukałem się drugiego przewodu na tych zdjęciach.

16

Odp: problem ze sprzętowym resetem na 74123

lemiel napisał/a:

Lt_Bri: w pierwszym poście jest link.

Nie doczytałem - mój błąd wink

wszystkie trzy strony świata