51

Odp: ACSI2STM - nowy dysk twardy ACSI dla ST/TT

A Drone / Dhs działa ??

p.s.
Nie nie mam i nie będę miał Atari 16bit.

Główną przyczyną rozwodów jest małżeństwo.

52

Odp: ACSI2STM - nowy dysk twardy ACSI dla ST/TT

@AS - looknij sobie w post #35: http://www.atari.org.pl/forum/viewtopic … 67#p272867

Drone nie działa z ACSI2STM. Tak samo Sea of Color. Jeszcze Rise of Black Storm od MSB.

grzybson/SSG

53

Odp: ACSI2STM - nowy dysk twardy ACSI dla ST/TT

Jest nowy firmware v2.0...

Zacznę od dobrych wiadomości, jak się go uda uruchomić to chodzi pięknie:
https://obrazki.elektroda.pl/3740510300_1620422418_thumb.jpg

Działa zarówno na oryginalnym STM32F103C8, jak i na CKS32F103C8. Przeszło moją próbę, czyli przegranie BadApple między partycjami i porównanie plików.

Teraz problemy:
Z nieznanych mi powodów, jeśli w Arduino IDE wybiorę programator STLink, to wsad się wgrywa, ale nie działa. Jeśli wgram po UART, albo wyeksportuję binarkę i wgram STM32 Cube Programmer przez STLink to działa.

Na STe działa bezbłędnie i szybko, na STf nie chce działać AutoBoot, a próba zapisu bootsectora "wysypała" zawartość karty.

Atari 1040STe (TOS 1.62/2.06 UK, 4MB RAM), Atari 1040STfm (TOS 1.04 UK, 4MB RAM, BLiTTER, Gotek HxC) + Digital Data Deicke HD64, SF314, UltraSatan, Gotek HxC, NetUSBee
Atari 800XE (SIMM EXP 1MB), Atari 800XL (RAMBO XL 256kB), Sinclair SPECTRUM+ (48kB), TIMEX Computer 2048 (48kB)
Commodore A600 (KS 1.3/3.1, 2MB CHIP RAM, 4MB FAST RAM, CF 4GB, Gotek FF)

54

Odp: ACSI2STM - nowy dysk twardy ACSI dla ST/TT

To i ja coś dopiszę.

W wersji pierwszej (tj. tej, którą produkował Zaxon) występują problemy z "krótkim" 520 ST (TOS 1.00, 1 MB RAM) i driverem Petera. Wszystko działa elegancko, niestety po resecie z przycisku z tyłu, partycje się "przesuwają". To znaczy, że jeśli mam partycje C, D, E, to po resecie zmieniają się na F, G, H. Poza tym wszystko inne działa, bez problemów - trzeba tylko pamiętać, żeby nie resetować, tylko wyłączać pstryczkiem ON / OFF.

Driver Petera w wersji zarejestrowanej, w najnowszej wersji. Ten sam setup działa z 1040STE i TOS 2.06 bez żadnych problemów. Peter twierdzi, że to niestety problem sprzętowy.

Czy możecie wyjaśnić, Stirlitz, dlaczego wasz służbowy adres stirlitz@rsha.gov.de ma aliasa justas@gru.su?
Nie czytam PM. Proszę używać e-mail.

55

Odp: ACSI2STM - nowy dysk twardy ACSI dla ST/TT

Peter zawsze twierdzi, że to problem sprzętowy ;) on nigdy nie dopuszcza możliwości błędu w swoim oprogramowaniu.

Atari 1040STe (TOS 1.62/2.06 UK, 4MB RAM), Atari 1040STfm (TOS 1.04 UK, 4MB RAM, BLiTTER, Gotek HxC) + Digital Data Deicke HD64, SF314, UltraSatan, Gotek HxC, NetUSBee
Atari 800XE (SIMM EXP 1MB), Atari 800XL (RAMBO XL 256kB), Sinclair SPECTRUM+ (48kB), TIMEX Computer 2048 (48kB)
Commodore A600 (KS 1.3/3.1, 2MB CHIP RAM, 4MB FAST RAM, CF 4GB, Gotek FF)

56

Odp: ACSI2STM - nowy dysk twardy ACSI dla ST/TT

dely napisał/a:

Driver Petera w wersji zarejestrowanej, w najnowszej wersji. Ten sam setup działa z 1040STE i TOS 2.06 bez żadnych problemów. Peter twierdzi, że to niestety problem sprzętowy.

Co masz na myśli w wersji zarejestrowanej?

57

Odp: ACSI2STM - nowy dysk twardy ACSI dla ST/TT

Mam na myśli to, że zarejestrowałem driver płacąc za niego pieniądze.

Czy możecie wyjaśnić, Stirlitz, dlaczego wasz służbowy adres stirlitz@rsha.gov.de ma aliasa justas@gru.su?
Nie czytam PM. Proszę używać e-mail.

58

Odp: ACSI2STM - nowy dysk twardy ACSI dla ST/TT

Wersja pierwsza (tj. tej, którą produkował Zaxon) testowane z TOS 2.06 ma MSTE, STE i krótkie 520ST. Wszystkie Atari po 4MB.
HDDRIVER 11.04 działa bezproblemowo, xferrate ~240kb/s - 260kb/s
PP Driver z 2014r.(czyli te co PP sprzedawał ażdo pojawienia się ACSI2STM), zwiechy TOS, i jest uczucie jakby system zamulał ATARI, wszystko powoli chodzi. xferrate ~240kb/s
PP driver z disk FAT16  filesystem , działa bezproblemowo, xferrate ~260kb/s
PP driver z 2021r. co Zaxon sprzedaje z ACSI2STM, działają bezproblemowo, xferrate ~340kb/s

Krótkie 520ST, TOS 1.04, testowane z 1MB i 4MB, wyniki takie same jak z TOS 2.06, ww.. Nie ma takiego problemu co opisuje @delly

Ostatnio edytowany przez dragmar (2021-06-02 08:46:26)

59

Odp: ACSI2STM - nowy dysk twardy ACSI dla ST/TT

Osiągi na aktualnym firmware:
Odczyt: 650 KB/s
Zapis: 375 KB/s

Mega ST 1 / 7800 / Portfolio / Lynx II / Jaguar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
DDD HDD / AT Speed C16 / TF536 / SDrive / PAK68/3 / Lynx Multi Card / LDW Super 2000 / XCA12 / SkunkBoard / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
http://260ste.atari.org

60

Odp: ACSI2STM - nowy dysk twardy ACSI dla ST/TT

dragmar napisał/a:

Krótkie 520ST, TOS 1.04, testowane z 1MB i 4MB, wyniki takie same jak z TOS 2.06, ww.. Nie ma takiego problemu co opisuje @delly

Czyli problem jest widać we współpracy sterowników PP z TOS 1.00. Z ciekawości w tzw. chwili wolnej sprawdzę czy podobny sytuacja jest z ICD.

Czy możecie wyjaśnić, Stirlitz, dlaczego wasz służbowy adres stirlitz@rsha.gov.de ma aliasa justas@gru.su?
Nie czytam PM. Proszę używać e-mail.