1

Temat: Zmontowałem SIC! carta i... SELF TEST.

Zmontowałem SIC! carta i... SELF TEST.

https://obrazki.elektroda.pl/2986472000_1579540066_thumb.jpg

Jako Flash użyłem Winbonda W29C020C zaprogramowanego w programatorze wsadem "SDX445_siccart.rom" ze strony projektu. TTLe serii LS, GAL 10ns (GAL16V8D-10LP) zaprogramowany wsadem "SICCAR.jed". Co robię nie tak? W 65XE wkładany scalakami do góry, w 800XL scalakami do klawiatury.

Ostatnio edytowany przez _tzok_ (2020-01-20 18:51:59)

Atari 1040STe (TOS 1.62/2.06 UK, 4MB RAM), Atari 1040STfm (TOS 1.04 UK, 4MB RAM, BLiTTER, Gotek HxC) + Digital Data Deicke HD64, SF314, UltraSatan, Gotek HxC, NetUSBee
Atari 800XE (SIMM EXP 1MB), Atari 800XL (RAMBO XL 256kB), Sinclair SPECTRUM+ (48kB), TIMEX Computer 2048 (48kB)
Commodore A600 (KS 1.3/3.1, 2MB CHIP RAM, 4MB FAST RAM, CF 4GB, Gotek FF)

2

Odp: Zmontowałem SIC! carta i... SELF TEST.

co to za elektrolit?
na wlaczonym komputerze zewrzyj go na chwile po czym wcisnij reset

Ostatnio edytowany przez Candle (2020-01-20 19:57:27)

przechodze na tumiwisizm

3

Odp: Zmontowałem SIC! carta i... SELF TEST.

Działa, flashowałem zewnętrznym programatorem i nie dodałem offsetu 8 kB na początku, myślałem że obrazy z dystrybucji SDX są "gotowe".

Elektrolit 1uF w obwodzie RC resetu... nie miałem innego pod ręką.

***

Jednak to nie tylko kwestia tego offsetu 8 kB. Te obrazy BIN z dystrybucji SpartaDOS X nie nadają się do wgrywania ich przy pomocy programatora.

Ostatnio edytowany przez _tzok_ (2020-01-21 17:06:12)

Atari 1040STe (TOS 1.62/2.06 UK, 4MB RAM), Atari 1040STfm (TOS 1.04 UK, 4MB RAM, BLiTTER, Gotek HxC) + Digital Data Deicke HD64, SF314, UltraSatan, Gotek HxC, NetUSBee
Atari 800XE (SIMM EXP 1MB), Atari 800XL (RAMBO XL 256kB), Sinclair SPECTRUM+ (48kB), TIMEX Computer 2048 (48kB)
Commodore A600 (KS 1.3/3.1, 2MB CHIP RAM, 4MB FAST RAM, CF 4GB, Gotek FF)

4

Odp: Zmontowałem SIC! carta i... SELF TEST.

Spróbuj zaprogramować z poziomu Atari programem do tego dedykowanym.

ADRES: pin@atari.pl - konto zlikwidowane. Aktualny adres: pin(at)atari8.info

5

Odp: Zmontowałem SIC! carta i... SELF TEST.

J/w - już działa. Teraz pytanie jak wrzucić na to obrazy prawdziwych kartridży? Da się w ogóle czy tylko XEXy i EXEki?

Tak samo zachowuje się Altirra jak i prawdziwe Atari. Menu wyświetla się dobrze, ale co bym nie wybrał to albo jest reset i wraca do menu albo zwisa.

***

OK, już znalazłem, tzn. @stryker mi pokazał.

Ostatnio edytowany przez _tzok_ (2020-01-20 23:12:17)

Post's attachments

games.bin 256 kb, liczba pobrań: 15 (od 2020-01-20) 

Tylko zalogowani mogą pobierać załączniki.
Atari 1040STe (TOS 1.62/2.06 UK, 4MB RAM), Atari 1040STfm (TOS 1.04 UK, 4MB RAM, BLiTTER, Gotek HxC) + Digital Data Deicke HD64, SF314, UltraSatan, Gotek HxC, NetUSBee
Atari 800XE (SIMM EXP 1MB), Atari 800XL (RAMBO XL 256kB), Sinclair SPECTRUM+ (48kB), TIMEX Computer 2048 (48kB)
Commodore A600 (KS 1.3/3.1, 2MB CHIP RAM, 4MB FAST RAM, CF 4GB, Gotek FF)