1

Temat: Krótkie Atari 520ST nie wstaje.

Jakieś czas temu pojawił się problem z moim krótkim 520ST (rozszerzonym do 2MB) (paski1jpg), ale komputer w sumie działał poprawnie, oprócz tych pasków.
Dzisiaj postanowiłem spróbować coś z tym zrobić. Rozpocząłem od wymiany kondensatorów, nic to nie dało, ale komputer działał normalnie. Następnie stwierdziłem, że wymienię gniazdo DIN13, bo stare miało swoje humory, czasami nie kontaktowało etc. niestety po jego wymianie komputer umarł sad. Po włączeniu pojawia się biały ekran z tym paskami z którymi walczyłem, ale nic po za tym sad, bomb nie ma, po kilkukrotnym naciśnięciu resetu, pojawiają się artefakty (reset1.jpg i reset.jpg).

Próbowałem odpalić cartrige diagnostyczny, ale nie wstaje, zasilacz sprawdziłem daje poprawne napięcia.

Możecie podpowiedzieć od czego zacząć analizę?

ps. dioda na klawiaturze świeci
ps2. stacja po podłączeniu też nie reaguje

Ostatnio edytowany przez lopez (2020-02-12 20:17:27)

Post's attachments

paski1.jpg 246.36 kb, nikt jeszcze nie pobierał tego pliku. 

reset.jpg 411.89 kb, nikt jeszcze nie pobierał tego pliku. 

reset1.jpg 381.02 kb, nikt jeszcze nie pobierał tego pliku. 

Tylko zalogowani mogą pobierać załączniki.

2

Odp: Krótkie Atari 520ST nie wstaje.

Kiedyś miałem problem z podstawkami PLCC pod MMU i GLUE. 520ST nie wstawał. Trzeba było wyciągnąć "kwadraty" z podstawek, wyczyścić nóżki na kartce papieru (teraz można użyć Kontakt S i Kontakt U) i po takim zabiegu na dłuższy czas problem znikał - niestety nie na zawsze.

http://raven1.magix.net   http://atari.000space.com
różne różności dla Atari i nie tylko - przydatne, bądź nie ale i tak warto zajrzeć...
Atari - Power without price and neccesary elements

3

Odp: Krótkie Atari 520ST nie wstaje.

Sprawdziłem, wyciągnąłem oczyściłem, bez zmian.

ps. z cartem diagnostycznym mam taki objaw, że nie startuje ale za to jak sie z nim kilka razy naciśnie reset to pojawia się zielony ekran.

4

Odp: Krótkie Atari 520ST nie wstaje.

Obstawiam problem z RAM. Paski mogą być artefaktami pochodzącymi od któregoś z sygnałów w systemie. Podobna jazda jak w małych Atari...

Ostatnio edytowany przez tOri (2020-02-12 21:14:48)

http://raven1.magix.net   http://atari.000space.com
różne różności dla Atari i nie tylko - przydatne, bądź nie ale i tak warto zajrzeć...
Atari - Power without price and neccesary elements

5

Odp: Krótkie Atari 520ST nie wstaje.

Pomierzyłem napięcia na układach i wszystko wygląda ok, a wiecie może czy bez kości TOS cartrige diagnostyczny powinien się odpalić ?

6

Odp: Krótkie Atari 520ST nie wstaje.

raster jest, paski - jakieś dane w pamięci są, ale tylko 8 bitów jest aktywne (co drugi pasek pusty)
coś parzy?

przechodze na tumiwisizm

7

Odp: Krótkie Atari 520ST nie wstaje.

Właśnie nic ponad standard, lekko ciepłe WD i CPU ale to normalne raczej.

ps. dzisiaj przytargam oscyloskop, może będzie łatwiej dojść co nie działa.

Ostatnio edytowany przez lopez (2020-02-13 08:57:29)

8

Odp: Krótkie Atari 520ST nie wstaje.

to wlacz na 20 minut i zobacz co jest wyjatkowo zimne

przechodze na tumiwisizm

9

Odp: Krótkie Atari 520ST nie wstaje.

Ok, wieczorem tak zrobię

10

Odp: Krótkie Atari 520ST nie wstaje.

Takiego czegoś jeszcze nie miałem, odcięta nóżka od kondensatora wleciał pomiędzy nogi kości TOS i powodowała zwarcie roll
Tak więc wrócił do żywych big_smile

Jednak nadal mam te nieszczęsne paski, skoro już mam go rozebranego to może macie pomysł co może powodować takie objawy? testowałem RAM programem YAART oraz cartem diagnostycznym i niby jest ok. Kondensatory wymienione, gniazdo wymienione, przewód AV też jest ok (na STE nie ma tego typu problemów).

Ostatnio edytowany przez lopez (2020-02-13 17:30:52)

11

Odp: Krótkie Atari 520ST nie wstaje.

Te paski są praktycznie na każdym ST, tylko na jednych rewizjach płyty są mniej widoczne, na innych bardziej. Dużo też zależy od monitora. W jednej płycie od spodu zrobiłem "pająka" rozprowadzającego zasilanie do głównych podzespołów i to trochę zmniejszyło te paski.

Atari 1040STe (TOS 1.62/2.06 UK, 4MB RAM), Atari 1040STfm (TOS 1.04 UK, 4MB RAM, BLiTTER, Gotek HxC) + Digital Data Deicke HD64, SF314, UltraSatan, Gotek HxC, NetUSBee
Atari 800XE (SIMM EXP 1MB), Atari 800XL (RAMBO XL 256kB), Sinclair SPECTRUM+ (48kB), TIMEX Computer 2048 (48kB)
Commodore A600 (KS 1.3/3.1, 2MB CHIP RAM, 4MB FAST RAM, CF 4GB, Gotek FF)

12

Odp: Krótkie Atari 520ST nie wstaje.

No właśnie nie bardzo, jak dobrze popatrzysz to do prawej strony nie ma ich wcale. Czasami zdarza się, że wstanie z obrazem idealnym bez tych pasków, ale nie wiem od czego to zależy i bardzo rzadko się to zdarza.
I co ciekawe paski są widoczne np podczas startu, pracy w TOS, ale podczas gier ich nie widać.

Ostatnio edytowany przez lopez (2020-02-13 18:12:34)

13

Odp: Krótkie Atari 520ST nie wstaje.

Czas na analizę rewizji płyt ST, jaką Mq zrobił z płytami XE smile i na projekt nowej, jak w wątku o nowej płycie 800XL/130XE smile

----====   dołącz do www.worldcommunitygrid.org   ===---

<-- Moja skrzynka "PW" jest pełna i nie mam czego usunąć. Chcesz się skontaktować, kliknij "E-mail". Dzięki.

14

Odp: Krótkie Atari 520ST nie wstaje.

Za późno, już jest płyta ST remake wink

Atari 1040STe (TOS 1.62/2.06 UK, 4MB RAM), Atari 1040STfm (TOS 1.04 UK, 4MB RAM, BLiTTER, Gotek HxC) + Digital Data Deicke HD64, SF314, UltraSatan, Gotek HxC, NetUSBee
Atari 800XE (SIMM EXP 1MB), Atari 800XL (RAMBO XL 256kB), Sinclair SPECTRUM+ (48kB), TIMEX Computer 2048 (48kB)
Commodore A600 (KS 1.3/3.1, 2MB CHIP RAM, 4MB FAST RAM, CF 4GB, Gotek FF)

15

Odp: Krótkie Atari 520ST nie wstaje.

Szukam nadal, czy uszkodzony Shifter może dawać takie objawy ?

16

Odp: Krótkie Atari 520ST nie wstaje.

Może, ale bardziej prawdopodobny jest słaby kontakt w podstawce lub pęknięty/zimny lut. Tego typu paski są charakterystyczne dla zakłóceń pochodzących z magistrali pamięci, mogą się też przenosić po zasilaniu. Pamięci DRAM bardzo "sieją".

Ostatnio edytowany przez _tzok_ (2020-02-14 10:24:47)

Atari 1040STe (TOS 1.62/2.06 UK, 4MB RAM), Atari 1040STfm (TOS 1.04 UK, 4MB RAM, BLiTTER, Gotek HxC) + Digital Data Deicke HD64, SF314, UltraSatan, Gotek HxC, NetUSBee
Atari 800XE (SIMM EXP 1MB), Atari 800XL (RAMBO XL 256kB), Sinclair SPECTRUM+ (48kB), TIMEX Computer 2048 (48kB)
Commodore A600 (KS 1.3/3.1, 2MB CHIP RAM, 4MB FAST RAM, CF 4GB, Gotek FF)

17

Odp: Krótkie Atari 520ST nie wstaje.

Mówisz o podstawce Shiftera ?

18

Odp: Krótkie Atari 520ST nie wstaje.

Może być Shifter, może być MMU, ale jak masz rozszerzenie pamięci to też może być jego sprawka i kwestia ułożenia taśm (jak masz to "dwupłytkowe" wkładane w podstawkę Shiftera).

Atari 1040STe (TOS 1.62/2.06 UK, 4MB RAM), Atari 1040STfm (TOS 1.04 UK, 4MB RAM, BLiTTER, Gotek HxC) + Digital Data Deicke HD64, SF314, UltraSatan, Gotek HxC, NetUSBee
Atari 800XE (SIMM EXP 1MB), Atari 800XL (RAMBO XL 256kB), Sinclair SPECTRUM+ (48kB), TIMEX Computer 2048 (48kB)
Commodore A600 (KS 1.3/3.1, 2MB CHIP RAM, 4MB FAST RAM, CF 4GB, Gotek FF)

19

Odp: Krótkie Atari 520ST nie wstaje.

Wszystkie układy w podstawkach dzisiaj wyciągnąłem, przeczyściłem i wsadziłem ponownie. Brak poprawy.
Rozszerzenie pamięci wygląda tak jak na zdjęciu, raczej ciężko coś tam poprawić.
Pozostały mi jeszcze do wymiany dwa kondensatory zaznaczone na czerwono, jutro je odlutuję i sprawdzę, ewentualnie wlutuje standardowe, chociaż wszystkie które do tej pory wymieniałem trzymały parametry.

Ma ktoś może jeszcze jakieś pomysły co mogę sprawdzić?

Post's attachments

plyta.jpg 226.01 kb, nikt jeszcze nie pobierał tego pliku. 

roz1.jpg 375.04 kb, nikt jeszcze nie pobierał tego pliku. 

Tylko zalogowani mogą pobierać załączniki.

20

Odp: Krótkie Atari 520ST nie wstaje.

Mam jeden pomysł - podłącz to na próbę do innego monitora. Ja kiedyś miałem paski w jednym Atari i okazało się, że to monitor tak "skaluje" obraz, że są te paski. Z innymi Atari tak nie robił, a z tym jednym tak. Na innym monitorze i na kineskopie obraz był OK.
Sprawdź inny monitor i powiedz też w jakich rozdzielczościach masz te paski.

21

Odp: Krótkie Atari 520ST nie wstaje.

U mnie na LCD czasem "wstaje" z obrazem na środku, czasem z przesuniętym w lewo. Nie wnikałem zbytnio w szczegóły ale tam był jakiś "myk" z fazą sygnału zegarowego (wakeup state/wakestate) między GLUE i MMU. Jakoś szczególnie więc mnie nie dziwi, że paski raz są, a raz ich nie ma.

Tutaj co nieco na ten temat:
http://www.atari-wiki.com/?title=ST_STE_Scanlines

Ostatnio edytowany przez _tzok_ (2020-02-14 22:48:28)

Atari 1040STe (TOS 1.62/2.06 UK, 4MB RAM), Atari 1040STfm (TOS 1.04 UK, 4MB RAM, BLiTTER, Gotek HxC) + Digital Data Deicke HD64, SF314, UltraSatan, Gotek HxC, NetUSBee
Atari 800XE (SIMM EXP 1MB), Atari 800XL (RAMBO XL 256kB), Sinclair SPECTRUM+ (48kB), TIMEX Computer 2048 (48kB)
Commodore A600 (KS 1.3/3.1, 2MB CHIP RAM, 4MB FAST RAM, CF 4GB, Gotek FF)

22

Odp: Krótkie Atari 520ST nie wstaje.

co mi tak swita ze bartek030 pisal o tym gdzies smile

Just a bunch of things that drygol does ... --> https://retrohax.net

23

Odp: Krótkie Atari 520ST nie wstaje.

lopez, to jest Lo-Res przez SCART/RGB? A Hi-Res przez przejściówkę na VGA jak wygląda? I czy jest zamiana przy wymuszeniu TV na 4:3?
Ew. jakbyś chciał to mogę wyciągnąć z czeluści SM124 i możemy u mnie podłączyć, albo ci pożyczę.
Mam też monitory LCD SCART 4:3 1280x1024 i CRT C=1084 z kablami do ST.
Mogę też podjechać do Ciebie z moimi ST-kami, w tym krótkimi 520ST+ i 260ST i ew. moim zasilaczem, zobaczyć na twoim TV.
Jakby co to dawaj na priv.

Ostatnio edytowany przez uicr0Bee (2020-02-15 11:38:19)

----====   dołącz do www.worldcommunitygrid.org   ===---

<-- Moja skrzynka "PW" jest pełna i nie mam czego usunąć. Chcesz się skontaktować, kliknij "E-mail". Dzięki.

24

Odp: Krótkie Atari 520ST nie wstaje.

x_angel napisał/a:

Mam jeden pomysł - podłącz to na próbę do innego monitora. Ja kiedyś miałem paski w jednym Atari i okazało się, że to monitor tak "skaluje" obraz, że są te paski. Z innymi Atari tak nie robił, a z tym jednym tak. Na innym monitorze i na kineskopie obraz był OK.
Sprawdź inny monitor i powiedz też w jakich rozdzielczościach masz te paski.

_tzok_ napisał/a:

był jakiś "myk" z fazą sygnału zegarowego (wakeup state/wakestate) między GLUE i MMU. Jakoś szczególnie więc mnie nie dziwi, że paski raz są, a raz ich nie ma.

O innych pasach mówicie.  Spotkałem trzy różne efekty pasów:

1) Mora - zmiana jasności w postaci pasów pionowych lub poziomych - zakłócenia sygnału antenowego lub composite (długość kabla ma wpływ)
http://www.atari.org.pl/forum/misc.php?action=pun_attachment&amp;item=6243

2) Złe skalowanie LCD - "tanie skalowanie" obrazu w LCD powoduje artefakty - różną grubość jednego piksela w różnych częściach obrazu:
http://www.atari.org.pl/forum/misc.php?action=pun_attachment&amp;item=6242

3) "wake up" mode SHIFTERa - pionowe czarne pasy o szerokości 16pikseli:
http://www.atari.org.pl/forum/misc.php?action=pun_attachment&amp;item=6241



Ten ostatni naprawia się najprościej - naciskając reset

Ostatnio edytowany przez Cyprian (2020-02-15 11:43:55)

Post's attachments

ST_16pixel black.png 1.43 kb, nikt jeszcze nie pobierał tego pliku. 

ST_LCD.png 4.63 kb, nikt jeszcze nie pobierał tego pliku. 

ST_Moire.jpg 56.41 kb, nikt jeszcze nie pobierał tego pliku. 

Tylko zalogowani mogą pobierać załączniki.
Portfolio / Lynx II / Jaguar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
SDrive / PAK68/3 / Lynx Multi Card / LDW Super 2000 / XCA12 / SkunkBoard / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
http://260ste.appspot.com

25

Odp: Krótkie Atari 520ST nie wstaje.

Po podpięciu do drugiego TV efekt jest jeszcze bardziej widoczny, na trzecim wygląda identycznie jak na pierwszym. Bez znaczenia low/mid-res jest to samo. Zmana skalowanie też nic nie zmienia.

Odłączyłem również to rozszerzenie, znaczy odlutowałem kabelek od MMU, wówczas komputer pokazuje tylko 512KB. ale również to nic nie zmieniło.

Ostatnio edytowany przez lopez (2020-02-15 13:49:41)

Post's attachments

monit1.jpg 714.06 kb, nikt jeszcze nie pobierał tego pliku. 

monit2.jpg 384.17 kb, nikt jeszcze nie pobierał tego pliku. 

Tylko zalogowani mogą pobierać załączniki.