1

Temat: Obraz - TOS 0.99

Znalazłem coś takiego z 1985 r.  http://koplinscy.fm.interiowo.pl/atari/TOS99.MSA Ponoć wersja 0.99 dyskietkowa, jeszcze przed 1.00. Może ktoś to sprawdzić i wersję, bo wydaje mi się, że nie obsługuje twardego dysku a nie bardzo mam teraz czas na testy. A jakby się komuś udało do tego wywołać zwiechę to ponoć ten TOS ma grzyba atomowego zamiast klasycznych bomb ;)

"The very first version of TOS used mushroom clouds; this was quickly changed"
http://en.wikipedia.org/wiki/Bomb_(symbol)

------add

Dziwne, normalnie 1.00 pokazuje mi tak:
http://koplinscy.fm.interiowo.pl/atari/TOS100_b.jpg
http://koplinscy.fm.interiowo.pl/atari/TOS100_a.jpg

a ten niby 0.99 tak:
http://koplinscy.fm.interiowo.pl/atari/TOS_a.jpg
http://koplinscy.fm.interiowo.pl/atari/TOS_b.jpg

jak widać różni się od 1.00 datą o kilka miesięcy, nr wersji AESu i GEMu.
ale jako nr wer. TOSa również pokazuje 1.00 :>
Być może to nie jest ów mityczny 0.99 z grzybami :/

Ostatnio edytowany przez erOS (2015-05-10 19:26:59)

Atari Falcon 030 14MB+SD16GB; Atari TT 030 4MB ST-RAM, 64 MB TT-RAM; Atari 1040 STFM; Atari 1040 STE 4MB+NetUsbee+UltraSatan; Commodore 64+1541-II+XE1541; Atari 65 XE+CA-2001+Ultimate 1MB+Side2;  P166MMX+GUS.

2

Odp: Obraz - TOS 0.99

przypomniałem sobie o tym i w końcu to sprawdziłem ;)
i potwierdzam: Tak ten TOS 0.99 ma zamiast bomb grzybki atomowe...

screen w pliku poniżej...


a tak pisze ponoć jeden z developerów:

"Initially the crash icon was indeed a mushroom cloud. This shipped in the 16K boot ROM that was in very early STs. We decided that the cloud didn't convey the message we wanted: It was a little dark, and quite a few people asked what was up with "all those little trees". So I changed it to a bomb."

Post's attachments

ST-cloud.png 5.25 kb, nikt jeszcze nie pobierał tego pliku. 

Tylko zalogowani mogą pobierać załączniki.
Atari Falcon 030 14MB+SD16GB; Atari TT 030 4MB ST-RAM, 64 MB TT-RAM; Atari 1040 STFM; Atari 1040 STE 4MB+NetUsbee+UltraSatan; Commodore 64+1541-II+XE1541; Atari 65 XE+CA-2001+Ultimate 1MB+Side2;  P166MMX+GUS.

3

Odp: Obraz - TOS 0.99

Ciekawa ciekawostka :) Fajnie że sprawdziłeś do końca.

--== Kup Pan/i dyskietkę - jedyna taka oferta w całym InterNecie - http://www.atari.org.pl/forum/viewtopic.php?id=18887 ==--

<-- Moja skrzynka "PW" jest pełna i nie mam czego usunąć. Kontakt przez "E-mail". Dzięki.

4

Odp: Obraz - TOS 0.99

@erOS zapodałbyś proszę tutaj na forum to TOS99.MSA i grafiki bo już nie są dostępne?

Dzięki

Lynx I / Mega ST 1 / 7800 / Portfolio / Lynx II / Jaguar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
DDD HDD / AT Speed C16 / TF536 / SDrive / PAK68/3 / Lynx Multi Card / LDW Super 2000 / XCA12 / SkunkBoard / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
http://260ste.atari.org

5

Odp: Obraz - TOS 0.99

@Cyprian

Proszę.

Niestety pod STEAM i hAtari nie wiem czy można odpalić bez załadowanego TOS ROMu,
więc odpalałem to tak, że obraz dyskietki do stacji a system jakiś angielski TOS 1.00 z listopada 1985
ze strony Avtandil'a - http://www.avtandil.narod.ru/tose.html system ładował się z IMG z flopa.
Niestety pod SYSInfo pokazuje nadal 1.0 z maja 1985, ale błędy generują słynne grzyby atomowe zamiast bomb.

Zawartość MSA to prawdopodobnie dyskietka Nr 1 (TOS System Disk) z GEM Developers Kit for the Atari ST.

Post's attachments

TOS99.zip 233.02 kb, liczba pobrań: 5 (od 2023-01-16) 

Tylko zalogowani mogą pobierać załączniki.
Atari Falcon 030 14MB+SD16GB; Atari TT 030 4MB ST-RAM, 64 MB TT-RAM; Atari 1040 STFM; Atari 1040 STE 4MB+NetUsbee+UltraSatan; Commodore 64+1541-II+XE1541; Atari 65 XE+CA-2001+Ultimate 1MB+Side2;  P166MMX+GUS.

Odp: Obraz - TOS 0.99

@erOS: musi być minimalny ROM, żeby cokolwiek odpalił z dyskietki. Taki jak w pierwszych ST bez TOSu.

Atari: FireBee, (Falcon030 CT60e SuperVidel SvEthlana CTPCI), TT, (520ST Pak030 Frak PuPla Panther), (520ST 4MB ST RAM 8MB TT RAM CosmosEx SC1435), (1040STFM UltraSatan SM124), (1040STE 4MB ST RAM 8MB TT RAM CosmosEx NetUSBee SM144 SC1224), 260ST, 520 ST+, (MEGA ST SM125), (65XE Rapidus U1MB VBXE SIDE2 SIO2PC), (Jaguar SkunkBoard), Lynx II, 2x Portfolio

7

Odp: Obraz - TOS 0.99

A ktoś sprawdzał, czy seltos oszukuje skutecznie sysinfo? I czy obsłuży tę wersję 0.99?

erOS napisał/a:

a tak pisze ponoć jeden z developerów:
[...]
This shipped in the 16K boot ROM that was in very early STs.

Gdzieś jest może upubliczniony ten 16k "boot ROM"?
P.S. to taki "za-przeproszeniem" kick-start ;)

--== Kup Pan/i dyskietkę - jedyna taka oferta w całym InterNecie - http://www.atari.org.pl/forum/viewtopic.php?id=18887 ==--

<-- Moja skrzynka "PW" jest pełna i nie mam czego usunąć. Kontakt przez "E-mail". Dzięki.

8

Odp: Obraz - TOS 0.99

Proszę bardzo — ROM loader dla TOS 0.99/1.00.

Post's attachments

tosload.img 16 kb, liczba pobrań: 5 (od 2023-01-17) 

Tylko zalogowani mogą pobierać załączniki.
Moja kolekcja: Atari 1040STe (4MB), Atari 1040STfm (4MB, BLiTTER, AT-ONCE+), Atari 800XE (SIMM EXP 1MB), Atari 800XL (RAMBO XL 256kB), Atari 600XL (64kB), Sinclair ZX SPECTRUM+ (48kB), TIMEX Computer 2048 (48kB), Commodore A600 (2MB+4MB, HDD CF 4GB), Commodore C64C.

9

Odp: Obraz - TOS 0.99

Merci very much. Chyba pierwszy raz to widzę.

--== Kup Pan/i dyskietkę - jedyna taka oferta w całym InterNecie - http://www.atari.org.pl/forum/viewtopic.php?id=18887 ==--

<-- Moja skrzynka "PW" jest pełna i nie mam czego usunąć. Kontakt przez "E-mail". Dzięki.

10

Odp: Obraz - TOS 0.99

Napiszę tukej co by nie mnożyć wątków.

Co może być przyczyną takich problemów:
aaa

przykładowe akcesorium:
bbb

gdyby "coś" "śmieciło" w pamięci ekranu problem nie dotyczyłby tylko liter.

Jest to obraz TOS załadowany do pamięci po modyfikacji.
Po załadowaniu sterownika do karty graficznej (NOVA) problemu już nie ma i wszystko jest czytelne (nawet gdy karta startuje w rozdzielczości 640x400 mono). Jeżeli tylko uruchomiony jest EMULATOR.PRG problem występuje. Gdzie szukać konfliktu (pamięć ekranu, czcionki)?

Było miło :) Do widzenia.

Odp: Obraz - TOS 0.99

Spróbuj bez pliku z ikonami.

Atari: FireBee, (Falcon030 CT60e SuperVidel SvEthlana CTPCI), TT, (520ST Pak030 Frak PuPla Panther), (520ST 4MB ST RAM 8MB TT RAM CosmosEx SC1435), (1040STFM UltraSatan SM124), (1040STE 4MB ST RAM 8MB TT RAM CosmosEx NetUSBee SM144 SC1224), 260ST, 520 ST+, (MEGA ST SM125), (65XE Rapidus U1MB VBXE SIDE2 SIO2PC), (Jaguar SkunkBoard), Lynx II, 2x Portfolio

12

Odp: Obraz - TOS 0.99

To nie to. Na drugim zrzucie widać że nawet w programach nie widać liter.

ccc

Było miło :) Do widzenia.

Odp: Obraz - TOS 0.99

Ale spróbowałeś? Jak plik z ikonami zrobi się 'za duży' (niestety nie wiem jaki jest limit, nie ma też żadnego ostrzeżenia) to się właśnie takie dziwne rzeczy potrafią dziać.

Atari: FireBee, (Falcon030 CT60e SuperVidel SvEthlana CTPCI), TT, (520ST Pak030 Frak PuPla Panther), (520ST 4MB ST RAM 8MB TT RAM CosmosEx SC1435), (1040STFM UltraSatan SM124), (1040STE 4MB ST RAM 8MB TT RAM CosmosEx NetUSBee SM144 SC1224), 260ST, 520 ST+, (MEGA ST SM125), (65XE Rapidus U1MB VBXE SIDE2 SIO2PC), (Jaguar SkunkBoard), Lynx II, 2x Portfolio

14

Odp: Obraz - TOS 0.99

Sprawdziłem, to nie to. W niskiej rozdzielczości i średniej jest to samo. Po załadowaniu sterowników do karty, zmienia się adres ekranu i jest OK, więc może jakaś poprawka "nachodzi" na ten obszar, tylko że wtedy powinny być zepsute nie tylko czcionki, ale i inne elementy na ekranie,. Szukam dalej.

Było miło :) Do widzenia.

15

Odp: Obraz - TOS 0.99

A zmienia się adres samych czcionek?

16

Odp: Obraz - TOS 0.99

FONTÓw, na miłość...
https://pl.wikipedia.org/wiki/Czcionka

Sikor umarł...

17

Odp: Obraz - TOS 0.99

Pisałem to i coś czułem, że Sikor będzie czujny.

Pójdźmy na kompromis. Czcionków. ;)

18

Odp: Obraz - TOS 0.99

Sikor napisał/a:

FONTÓw, na miłość...
https://pl.wikipedia.org/wiki/Czcionka

Głupszego śrudua już podać nie mogłeś. "Czcionka" jest polskim wyrazem, a "font" zapożyczeniem.
https://sjp.pwn.pl/sjp/czcionka;2450355.html

Zawsze mam rację, tylko nikt mnie nie słucha.

19

Odp: Obraz - TOS 0.99

Sikor już wielokrotnie wyjaśniał:

http://www.atari.org.pl/forum/viewtopic … 50#p297050
http://www.atari.org.pl/forum/viewtopic … 38#p280338
http://www.atari.org.pl/forum/viewtopic … 62#p275862
http://www.atari.org.pl/forum/viewtopic … 62#p266162
http://www.atari.org.pl/forum/viewtopic … 34#p266134

Osobiście przyznaję mu rację, co niestety nie do końca chroni mnie przed sporadycznym używaniem niewłaściwego wyrazu.
W sumie niepotrzebnie brniemy w offtop.

20

Odp: Obraz - TOS 0.99

Nie o wyjaśnienia chodzi, a źródło. Nawet, biorąc pod uwagę definicję słowa "font" przedstawioną przez PWN, to nadal w tym kontekście pasuje "czcionka".

Zawsze mam rację, tylko nikt mnie nie słucha.

21

Odp: Obraz - TOS 0.99

@lizard: czcionka to pojedynczy znak, font to  garnitur znaków, więc nijak nie pasuje. Jak by miał być kompromis - to krój by przeszedł.
==>Edyta powiedziała, że literówka była ;P

Ostatnio edytowany przez Sikor (2023-01-23 19:23:53)

Sikor umarł...

22

Odp: Obraz - TOS 0.99

Sikor napisał/a:

FONTÓw, na miłość...
https://pl.wikipedia.org/wiki/Czcionka

W dzisiejszych czasach, gdy jest tak wiele niewiadomych, należy doceniać to co pewne. A tego się spodziewałem, jak tylko użyłem słowa "czcionka" tudzież "font" :)


VLX napisał/a:

A zmienia się adres samych czcionek?

Nie wiem czy dobrze rozumuję, ale gdyby coś je zmutowało, to byłoby to powtarzalne, a tutaj raz widać "A", a raz nie widać tej litery.

EDIT:
Mam dodatkowy trop. Przy starcie test pamięci wygląda normalnie, następnie zgłasza się xboot i część napisów jest już zniekształcona. Wybrałem sam plik NVDI.PRG i pulpit zgłosił się normalnie bez zniekształceń. Jak wiadomo NVDI instaluje czcionki/fonty i to rozwiązało problem, czy zatem oznacza to, że coś nadpisuje obszar pamięci zajęty przez czcionki ?
Tak w ogóle to temat dotyczy TOS4.04 (ten z Falcona) którego chcę uruchomić na PAK-u.
A tak to wygląd po załadowaniu NVDI:

fff

Ostatnio edytowany przez artik-wroc (2023-01-24 12:33:56)

Było miło :) Do widzenia.