Temat: Martwy falcon

Moj Falcon nie chce wspolpracowac... Czarny ekran i nic wiecej.
Wiem ze chyba mam problem z resetem bo U2 pin 2 jest 0v (a o ile wiem powinno byc HIGH). Ale po paru nacisnieciach resetu w koncu pojawia sie high, monitor sie wlacza ale pojawia sie sygnal "out of range" (monitor to multisync i dziala bez problemu z TT i innymi starociami)
Mierzylem napiecie - wszystko OK. Na CPU pin 6 mam 8MHz (chyba tak powinno byc). Mam watpliwosci co do CPU bo pin 7 jest podniesiony i przylutowany kabelkiem do U67 a piny 18 i 19 sa podniesione. Z tego co wiem to na niektorych plytach pin 7 jest fabrycznie podciagniety do U67 a w dokumentacji - o ile widze - piny 18 i 19 nie sa uzywane (wiec to chyba nie jest problem).
Ma ktos jakis pomysl co robic dalej? Nie mam niestety oscyloskopu ani testowego cartridga...

2

Odp: Martwy falcon

Jaki masz stan na sygnałach BEER (pin 130 CPU) i HALT (pin 129 CPU)? Reset na procesorze OK (pin64)? 8MHz pojawia się tylko na chwilę, potem Combel powinien przełączyć na 16MHz. Sprawdź, czy jakaś noga Combela, CPU, Videla lub SDMA nie odlutowała się. Zwora na J20 założona (pin 20 i 22)? Masz inny moduł pamięci na podstawienie?

Falcon030 14MB + CT60; Jaguar + Skunkboard; 65XE + SIO2SD + Ultimate + Stereo + VideoMod; 520STE + 4MB + Ultrasatan + HxC Emulator;  LYNX II + VGA Mod; A2600 + MultiCart; ZX Spectrum 128k +2 + PiocDivSD;  Amiga 600 + 2MB chip + Furia + SD;  C64 "chlebak" + 1541 Ultimate

3

Odp: Martwy falcon

Odświeżam po długiej przerwie...
BERR - HIGH
HALT - HIGH
RESET - HIGH

Wszystko chyba zgodnie z service manualem..
Wymieniłem przycisk reset żeby nie mieć wątpliwości co do niego - teraz reset działa jak powinien.
8MHz jest na pinie 6 CPU ciągle - nie zmienia się na 16MHz nawet po paru minutach...
Zworka na J20 jest jak powinna...
Wymieniłem też NVRAM..

CPU grzeje się dość mocno (po 2-3 minutach zbyt długo nie da się go macać)...

Chipy niby sprawdzałem (na miarę swoich możliwości) i wygląda że wszystkie nóżki są ok. Płyta też nie wygląda na manipulowaną (choć nie wiem czy CPU nie był wymieniany).

Podłączona klawiatura nie daje żadnych oznak życia (żadnych dźwięków). Flop tak samo.

Jakieś inne sugestie...?

4

Odp: Martwy falcon

Jeżeli CPU parzy po chwili pracy to dobrze nie wróży, szczególnie że było coś kombinowane przy nim.
Do podstawienia na szybko masz jeszcze komplet Gal'i, często padają. Dalej to już praca z oscyloskopem i sprawdzenie przebiegów na magistralach.

Falcon030 14MB + CT60; Jaguar + Skunkboard; 65XE + SIO2SD + Ultimate + Stereo + VideoMod; 520STE + 4MB + Ultrasatan + HxC Emulator;  LYNX II + VGA Mod; A2600 + MultiCart; ZX Spectrum 128k +2 + PiocDivSD;  Amiga 600 + 2MB chip + Furia + SD;  C64 "chlebak" + 1541 Ultimate

5

Odp: Martwy falcon

"komplet Gal'i" brzmi dla mnie niezrozumiale wink) - moge je gdzies kupic (i co konkretnie...)?

Jeszcze jedno mnie zastanawia - dlaczego mam na pinie 6 ciagle 8MHz...? Pozostale sygnaly na CPU (BERR, HALT, RESET) wydaja sie byc OK (zakladam optymistycznie ze CPU nie jest martwy)..
Jest jakis sygnal na CPU ktory moge swoimi ograniczonymi narzedziami sprawdzic..? Zeby potwierdzic ze CPU daje jakiekolwiek oznaki zycia?

EDIT: patrzac na pinout w service manualu chyba raczej takiego sygnalu nie ma..
natomiast COMBO na pinie 1 (BMODE) powinien byc LOW (z tego co pisza normalnie jest HIGH i przelacza sie na low jesli bus masterem jest 68030)... Wiec jak bedze mial LOW to by znaczylo ze CPU zyje...?
Dodatkowo pin 42 na COMBO (BERR) powiniem byc HIGH...
Dobrze mysle?

EDIT: kolejny edit - BMODE jest LOW, BERR na COMBO jest HIGH... Czyli wszystko wyglada OK...
Sprawdzam tez pin 20 combo (clock) i wychodzi mi... 0 (podobnie jak na samym oscylatorze) ale to moze byc moj miernik bo wlasnie sprawdzilem specyfikacje i mierzy tylko do 10mhz... Tak ze te 16mhz tez na CPU moze byc tylko moj miernik po prostu go nie widzi i zatrzymuje sie na ostatnim znanym czyli 8mhz...

nie bardzo wiem za co sie zabrac... to chyba wszystko co moglem swoim skromnym sprzetem sprawdzic..
jesli ktos ma jakis pomysl - prosze o info...

Ostatnio edytowany przez damanloox (2018-11-02 18:30:26)

6

Odp: Martwy falcon

Komplet GAL'i -obok NVRAM,u masz cztery kości z układami programowalnymi GAL16V8 (U62,U63,U67,U68 piszę z pamięci). Potrafią paść. Wsady do tych układów są dostępne.
Bez oscyloskopu nic nie zdziałasz, trzeba obejrzeć czy są przebiegi na magistralach adresowych i danych, no i oczywiście CLK.

Falcon030 14MB + CT60; Jaguar + Skunkboard; 65XE + SIO2SD + Ultimate + Stereo + VideoMod; 520STE + 4MB + Ultrasatan + HxC Emulator;  LYNX II + VGA Mod; A2600 + MultiCart; ZX Spectrum 128k +2 + PiocDivSD;  Amiga 600 + 2MB chip + Furia + SD;  C64 "chlebak" + 1541 Ultimate

7

Odp: Martwy falcon

Czuba przewidział to że te gale lubią padać i po prostu je wyciął przy Falconie z ct2b (bo są zupełnie nie potrzebne smile ).
No musiałem zatrolować smile

Główną przyczyną rozwodów jest małżeństwo.

8

Odp: Martwy falcon

GALe sa OK... Zgralem oryginaly i zawartos identyczna z tymi co sa na sieci. Wlozylem nowe i zero zmian.
Jedyne co mi sie udalo to uzyskac zielony ekran... Nic poza tym... Kart diagnostyczny nic nie daje (nawet na konsole)