1

Temat: Problem z klawiaturą 520STFM

Wpadło w moje ręce uszkodzone Atari 520STFM, uszkodzona jest klawiatura. Nie działają klawisze jak na zdjęciu oraz dodatkowo myszka idzie w górę, przy ruchy w dół (tu obstawiam 74LS244 do wymiany w klawiaturze).

Czy ma ktoś doświadczenie co może być uszkodzone, że nie działają te klawisze? Ścieżki przejrzałem, wyglądają ok.

http://www.atari.org.pl/forum/misc.php?action=pun_attachment&item=7042

Ostatnio edytowany przez lopez (2020-11-12 21:13:39)

Post's attachments

klawiatura.jpg 134.53 kb, nikt jeszcze nie pobierał tego pliku. 

Tylko zalogowani mogą pobierać załączniki.

2

Odp: Problem z klawiaturą 520STFM

Myślę, że to powinno Ci pomóc:
https://obrazki.elektroda.pl/5407662000_1605214541_thumb.jpg

Atari 1040STe (TOS 1.62/2.06 UK, 4MB RAM), Atari 1040STfm (TOS 1.04 UK, 4MB RAM, BLiTTER, Gotek HxC) + Digital Data Deicke HD64, SF314, UltraSatan, Gotek HxC, NetUSBee
Atari 800XE (SIMM EXP 1MB), Atari 800XL (RAMBO XL 256kB), Sinclair SPECTRUM+ (48kB), TIMEX Computer 2048 (48kB)
Commodore A600 (KS 1.3/3.1, 2MB CHIP RAM, 4MB FAST RAM, CF 4GB, Gotek FF)

3

Odp: Problem z klawiaturą 520STFM

Dzięki, widzę, że nie działają dokładnie linie D7, D5, D4 - sprawdzę jeszcze raz ciągłość ścieżek.

Czy uwalony 74LS244N może też powodować niedziałanie klawiszy ?

Ostatnio edytowany przez lopez (2020-11-12 22:28:13)

4

Odp: Problem z klawiaturą 520STFM

A tak z głowy: w klawiaturach ST nie siedzi kontroler w podstawce? Bo może mu się styki zaśniedziały i wystarczy wyjąć/wsadzić i będzie git?

5

Odp: Problem z klawiaturą 520STFM

No i wszystko jasne, wymiana LS244 nic nie dała, ale po podmianie kontrolera HD6301V1P z innej klawiatury i wszystko śmiga, więc mam winowajcę.

Jak rozumiem HD6301V1P z ebay'a czy alliexpres nie będzie dobrym zamiennikiem?

https://www.ebay.com/p/1523816508 na obrazku wygląda tak samo, ale i tak nie wiadomo co chińczyk wyśle sad

6

Odp: Problem z klawiaturą 520STFM

To jest MCU, więc układ programowalny...

Atari 1040STe (TOS 1.62/2.06 UK, 4MB RAM), Atari 1040STfm (TOS 1.04 UK, 4MB RAM, BLiTTER, Gotek HxC) + Digital Data Deicke HD64, SF314, UltraSatan, Gotek HxC, NetUSBee
Atari 800XE (SIMM EXP 1MB), Atari 800XL (RAMBO XL 256kB), Sinclair SPECTRUM+ (48kB), TIMEX Computer 2048 (48kB)
Commodore A600 (KS 1.3/3.1, 2MB CHIP RAM, 4MB FAST RAM, CF 4GB, Gotek FF)

7

Odp: Problem z klawiaturą 520STFM

To jak poznać pasujący?

8

Odp: Problem z klawiaturą 520STFM

Musi pochodzić z klawiatury Atari ST, czyli mieć oznaczenie "C070122-002". Ich pamięć programu to ROM, więc były "programowane" na etapie produkcji chipu.

Atari 1040STe (TOS 1.62/2.06 UK, 4MB RAM), Atari 1040STfm (TOS 1.04 UK, 4MB RAM, BLiTTER, Gotek HxC) + Digital Data Deicke HD64, SF314, UltraSatan, Gotek HxC, NetUSBee
Atari 800XE (SIMM EXP 1MB), Atari 800XL (RAMBO XL 256kB), Sinclair SPECTRUM+ (48kB), TIMEX Computer 2048 (48kB)
Commodore A600 (KS 1.3/3.1, 2MB CHIP RAM, 4MB FAST RAM, CF 4GB, Gotek FF)

9

Odp: Problem z klawiaturą 520STFM

Podczepię się pod temat. Podobne objawy z myszką mam w przypadku Megi STe. Zarówno myszka oryginalna jak i podłączona przez przejściówkę myszka zastępcza, źle interpretuje osie kierunku. Dziwne jest to, że mam dwie klawiatury do Megi STe  i na dwóch reaguje z takim samym błędem. Dobrze za to działa  klawiatura od Megi ST.
Jest taka możliwość, żeby "padnięte" były dwie klawiatury od wersje STe? A jeżeli tak, to jak sprawdzić co może być uszkodzone? Klawisze  i joystick, wszystko działa bez problemu. Jedyny niepokojący jeszcze objaw całej maszyny, że po wygrzaniu się zaczyna mocniej "sypać" zakłóceniami po obrazie /jakby tracił synchro - zarówno antena jak i euro/  jak i po torze audio. Nie wygrzana gra bez trzasków. Najbardziej słyszalne w sekcji dźwięku przez przetworniki.

Czy uwalony 74LS244N może sadzić takimi błędami?
ps. zupełnie nie znam się na elektronice w STE

bzzzz...bzzzzz..... o wgrało się !!!!

10

Odp: Problem z klawiaturą 520STFM

Nie wiem czy klawiatura w Mega STe jest taka sama, ale LS kosztuje ze 2zł to nic nie szkodzi wymienić i sprawdzić. W moim wypadku nic to nie zmieniło, niestety.

11

Odp: Problem z klawiaturą 520STFM

A tak się zastanawiam, bo sam zanabyłem taki niepasujący jak się okazało - nie dałoby się jakoś zastąpi tego układu od klawiatury? Albo wymusić działanie z RAM-u i jakoś mu podpinać "statyczną" pamięć od zewnątrz? Tak się pytam, bo na ST się ie znam, ale dociekliwy jestem, a kontrolerów klawiatury coraz mniej (ja na szczęście na zapas brałem).

Sikor umarł...

12

Odp: Problem z klawiaturą 520STFM

Znalazłem na ebay'u gościa co sprzedaje niby do Atari. Ok 80 zł wysyłką z UK wychodzi, jak by ktoś też szukał.

Ostatnio edytowany przez lopez (2020-11-17 08:42:55)

13

Odp: Problem z klawiaturą 520STFM

@Sikor - nie da się nic zrobić. Jak napisał _tzok_ musi być dla Atari specjalnie zaprogramowany.

http://raven1.magix.net   http://atari.000space.com
różne różności dla Atari i nie tylko - przydatne, bądź nie ale i tak warto zajrzeć...
Atari - Power without price and neccesary elements

14

Odp: Problem z klawiaturą 520STFM

@tOri: dlatego się zdziwiłem wink

Sikor umarł...