Temat: Atari ST + Megafile 20

Cześć

Dzięki uprzejmości kolegi Ariva od jakiegoś czasu korzystam z Megafile 20. Trochę czasu trwało zanim doprowadziłem go do stanu by się nie resetował (recap zasilacza i poprawienie zimnych lutów), potem dorobiłem kabelek i próbuję jakoś dogadać się z napędem z poziomu ST.

Niestety pojawiają się następujące problemy:
1. Korzystam z Goteka i o ile bez MF20 działa on poprawnie, po podłączeniu MF20 przestaje - nic się nie czyta.
2. Po podłączeniu MF20 w TOS pojawia mi się dodatkowy napęd B - nic się z niego nie da przeczytać.

Kabelek zrobiłem 1-1, długość około 50cm, czyli takie minimum przy którym da się podłączyć do ST stojące obok MF20.
Oczywiście biorąc pod uwagę, że MF20 jest z odzysku, może po prostu nie działać, ale może ktoś podpowie co jeszcze można by spróbować zrobić, by zmusić go do pracy. Chętnie wczytam jakieś drivery, tylko bez Goteka może być ciężko, więc najpierw wypadałoby rozwiązać problem współdziałania obu napędów.

Ostatnio edytowany przez maciekb (2021-03-22 14:39:41)

65xe, 520st, 1040stf

2

Odp: Atari ST + Megafile 20

może to bardzo głupie co teraz napiszę ale kiedyś potknąłem się o "niedziałającego" megafile'a a ostatecznie okazało się że pomyliłem w nim porty acsi. To nie to? smile

ADRES: pin@atari.pl - konto zlikwidowane. Aktualny adres: pin(at)atari8.info

3

Odp: Atari ST + Megafile 20

maciekb, jakie to dokładnie ST i jaka wersja TOS? Możesz sprawdzić uruchamiając SysInfo.

Ikony A i B na desktopie powinny być widoczne już przy podłączeniu jednej stacji (lub Goteka), bez podłączonego dysku twardego. Masz tak przy podłączonym tylko Goteku?

Zakładając że w komputerze nie ma jakiegoś przełącznika A/B, to "B" jest stacją zewnętrzną (w STF/STFM/STE - gdzie A to stacja wewnątrzna) i nic nie przeczytasz z "B" bez podłączonej drugiej stacji.
Za to, przez przeciągnięcie myszą ikony A na ikonę B możesz za pomocą jednej stacji skopiować zawartość jednej dyskietki (obrazu w Goteku) na drugą dyskietkę (z tym że CHYBA sformatowaną wcześniej na tę samą pojemność). Działa tak u Ciebie? W takim razie Gotek raczej prawidłowo emuluje FDD.

Dalej, WYDAJE mi się że samo podłączenie twardego dysku bez załadowania sterownika HDD (z tego dysku lub FDD) nie powoduje jeszcze pojawienia się dodatkowej ikony. Po załadowaniu sterownika HDD powinien się natomiast w systemie pojawić napęd "C" (i ew. dalsze litery) a nie B.
Dodatkowo w różnych wersjach TOS inaczej dodaje się ikony napędów do pulpitu. Dlatego pytałem o wersję TOS.

Skoro po podłączeniu MF20 Gotek przestaje działać całkowicie, to może kabel DMA nie jest poprawnie zrobiony?

Nie masz fizycznej stacji do podłączenia za Goteka, żeby jeszcze wykluczyć że to Gotek bruździ?

----====   dołącz do www.worldcommunitygrid.org   ===---

<-- Moja skrzynka "PW" jest pełna i nie mam czego usunąć. Kontakt przez "E-mail". Dzięki.

4

Odp: Atari ST + Megafile 20

Kabel ACSI jest 1:1 ale zwłaszcza w STf(m) (brak buforowania sygnałów portu ACSI) musi być naprawdę krótki - 20-30 cm. Ja robiłem z kabla Centronics od drukarki.

Atari 1040STe (TOS 1.62/2.06 UK, 4MB RAM), Atari 1040STfm (TOS 1.04 UK, 4MB RAM, BLiTTER, Gotek HxC) + Digital Data Deicke HD64, SF314, UltraSatan, Gotek HxC, NetUSBee
Atari 800XE (SIMM EXP 1MB), Atari 800XL (RAMBO XL 256kB), Sinclair SPECTRUM+ (48kB), TIMEX Computer 2048 (48kB)
Commodore A600 (KS 1.3/3.1, 2MB CHIP RAM, 4MB FAST RAM, CF 4GB, Gotek FF)

5

Odp: Atari ST + Megafile 20

Dzięki za wszystkie odpowiedzi, to może po kolei:
@Pin: Szczerze mówiąc nie wiem, czy porty pomyliłem smile Próbowałem w obu. W IN nic się nie dzieje, ale Gotek działa, próbowałem wczytywać jakieś sterowniki, które mi w ręce wpadły - nic się nie wykrywa (może niewłaściwe sterowniki?). W OUT jest jak wcześniej opisałem.
@uicr0Bee: EmuTOS 1.0. Normalnie w TOS widzę tylko stację A, niezależnie czy jest to fizyczna stacja (niestety uszkodzona), czy Gotek. Podłączenie MF20 (port OUT) do ST powoduje pojawienie się stacji B (pojawia się ona już na starcie TOS, czyli na ekranie powitalnym, przed boot) i jednocześnie psuje pracę Goteka.
@_tzok_: Ja użyłem przewodu 20x0.25 w ekranie, dedykowanego do transmisji danych, ale może rzeczywiście jest za długi. Dobra, postaram się zrobić krótszy.

65xe, 520st, 1040stf

6

Odp: Atari ST + Megafile 20

A nie masz kostek z TOSem Atari 1.04, czy 1.62 (zależnie od tego czy masz ST czy STE - bo tego jeszcze nie podałeś).
Nie używałem EmuTOSa w fizycznej maszynie, jedynie w emulatorze Hatari.

Kabel DMA idący z komputera podłącza do IN w MF. OUT jest do podłączenia kolejnego dysku.

Co do drivera, to poczciwy Atari Hard Disk Utilities / Atari Hard Disk Driver (AHDI) powinien wykryć MF20, jeżeli sprawne są: sam dysk, kabel i kontroler ACSI w ST... no przynajmniej z oryginalnym TOSem.

Myślę że należałoby dalszą diagnostykę wykonać w innym ST z oryginalnym TOSem, oryginalną FDD i na sprawdzonym kablu, na którym działa inny dysk. Dopiero gdy tam ten MF zadziała, to walczyć dalej.

----====   dołącz do www.worldcommunitygrid.org   ===---

<-- Moja skrzynka "PW" jest pełna i nie mam czego usunąć. Kontakt przez "E-mail". Dzięki.

7

Odp: Atari ST + Megafile 20

@uicr0Bee: mam ST, TOS 1.04 mogę sobie zaprogramować, ale sysinfo wykrywa mi ten EmuTOS jako 1.04, więc nie wiem czy akurat z tym warto walczyć. W każdym razie dzięki za wskazanie właściwego portu, teraz przynajmniej nie szarpię się z przekładaniem wtyczek wink

Z kronikarskiego obowiązku napiszę, że pościągałem trochę driverów i powtórzyłem testy. Coś się zaczęło wykrywać przy użyciu HDDRIVERa by Uwe Seimet - przy starcie pojawiał się komunikat o wykryciu urządzenia ACSI 0.0 Atari SH/Megafile, ale brak partycji. W pakiecie jest narzędzie HDDRUTIL, gdzie można np. sprawdzić sektory dysku i po wybraniu tej opcji dysk zaczyna pracowicie mielić, próbując dobrą chwilę coś odczytać, a następnie pojawia się komunikat o braku możliwości odczytu root sektora. Czy mam rozumieć, że Seagate ST-225 nie chce działać??? Ale jak to? wink
Nie chcę za bardzo kombinować, bo może jakimś cudem uda się coś z tego dysku odczytać. Ma ktoś jeszcze jakieś pomysły odnośnie walki o odczyt? Aktualnie narzędzie pozwala mi wybrać jedynie opcję formatowania medium, ale gdy jej użyję to zapewne już będzie po wszystkich danych. Mogę jeszcze czegoś spróbować?

Ostatnio edytowany przez maciekb (2021-04-06 00:39:23)

65xe, 520st, 1040stf

8

Odp: Atari ST + Megafile 20

maciekb napisał/a:

@uicr0Bee: mam ST, TOS 1.04 mogę sobie zaprogramować, ale sysinfo wykrywa mi ten EmuTOS jako 1.04

EmuTOS 192k zgłasza się jako 1.04; a 256k/512k jako 2.05

Mega ST 1 / 7800 / Portfolio / Lynx II / Jaguar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
DDD HDD / AT Speed C16 / TF536 / SDrive / PAK68/3 / Lynx Multi Card / LDW Super 2000 / XCA12 / SkunkBoard / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
http://260ste.atari.org

9

Odp: Atari ST + Megafile 20

Jeśli przed odstawieniem "do szafy" nie był prawidłowo zaparkowany to wielce prawdopodobne, że zdechł. Mnie się udało ożywić mój Megafile 60 przy pomocy ICD Pro, ale musiałem wykonać formatowanie niskopoziomowe. Bez tego był błąd ścieżki 0 i dysk odmawiał dalszej współpracy.

Atari 1040STe (TOS 1.62/2.06 UK, 4MB RAM), Atari 1040STfm (TOS 1.04 UK, 4MB RAM, BLiTTER, Gotek HxC) + Digital Data Deicke HD64, SF314, UltraSatan, Gotek HxC, NetUSBee
Atari 800XE (SIMM EXP 1MB), Atari 800XL (RAMBO XL 256kB), Sinclair SPECTRUM+ (48kB), TIMEX Computer 2048 (48kB)
Commodore A600 (KS 1.3/3.1, 2MB CHIP RAM, 4MB FAST RAM, CF 4GB, Gotek FF)

10

Odp: Atari ST + Megafile 20

Pochodzenie tego MF20 to PSZOK, więc nie mam pewności, czy poprzedni właściciel zaparkował głowice smile

65xe, 520st, 1040stf

11

Odp: Atari ST + Megafile 20

Jak nim ktoś tam rzucał, co chyba można założyć z dużą dozą prawdopodobieństwa, to zaparkowanie niewiele pomogło.

----====   dołącz do www.worldcommunitygrid.org   ===---

<-- Moja skrzynka "PW" jest pełna i nie mam czego usunąć. Kontakt przez "E-mail". Dzięki.

12

Odp: Atari ST + Megafile 20

Obudowy Atari nie za dobrze znoszą rzucanie, więc można założyć, że rzucany nie był, gdyż obudowa jest bez zarzutu.

65xe, 520st, 1040stf

13

Odp: Atari ST + Megafile 20

Na dysku masz ustawienie ID. Nie pamiętam jak to jest w ACSI, ale spróbowałbym:
- zmienić ID (powinien być przełącznik, dipswitch lub zwora)
- zastosować terminator w zączu OUT (może być też zwora lub coś w tym rodzaju).
O, tu chyba jest manual: https://docs.dev-docs.org/htm/search.php?find=_H

Sikor umarł...