26

Odp: c't IDE

Podchwyciłem ten patent z zasilaniem od Amigowców:-) Tam widziałem kilka interfejsów IDE pod procesor i oni zwykle robią w tych interfejsach tak, że doprowadzają ścieżkę z +5V do pinu 20 złącza IDE, ale po drodze dają jeszcze jumper lutowalny, że jak się montuje taki interfejs, to można to +5V tam podlutować tym jumperem, lub zostawić odłączone. Może w jakichś przypadkach ma to znaczenie i jakieś urządzenia mają z tym problem dlatego tak jest, nie wiem.
W każdym razie jak byś robił jeszcze jakieś płytki IDE, to warto tam dociągnąć zawsze alternatywnie to zasilanie dla przejściówek, żeby od razu było dostępne.

27

Odp: c't IDE

_tzok_ napisał/a:

@artik-wroc - wciąż czekam na obiecany tutorial do tos-patch'a...

  1. Pobierz odpowiedni Patch (np "TosPatch 1.04 german V2.1 beta") ze strony: https://www.markusheiden.de/atari/tospatch.html

  2. Zgodnie z instrukcją musisz mieć odpowiednią niemiecką wersję TOS.
    Np "TOS104GE.IMG" jest tutaj: "TOS 1.04     Deutsch" https://www.atariworld.org/tos-rom/ 
    Wgraj go do katalogu z "TOSPATCH.TTP" i zmień mu nazwę na "ST_TOS.IMG"

  3. Wyedytuj plik "104_REL.FIL"
    np zmień relokację z:
    ">1 3D0000 ;   4MB-Rechner / 1 File"

    na:
    ">1 FC0000 ;   4MB-Rechner / 1 File"

    Włącz podmianę fontów:
    z:
    ".FONTS = 0"
    na:
    ".FONTS = 1"

  4. wykonaj TOSPATCH.TTP z komendą:   104_REL.FIL.
    Zostanie utorzony nowy plik "TOS.IMG"

TOSPATCH.TTP z komendą: SPLIT1_6.FIL dzieli "TOS.IMG" na 6 plików LO/HI
Więcej w "README1.TXT"

Ostatnio edytowany przez Cyprian (2019-02-17 20:02:18)

Lynx II / Jaguar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
SDrive / PAK68/3 / Lynx Multi Card / LDW Super 2000 / XCA12 / SkunkBoard / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
http://260ste.appspot.com

28

Odp: c't IDE

Dzięki, za w/w ale bardziej mi zależało na pracy z zasobami - konkretnie pod kątem przygotowania tłumaczenia (eksportu/importu RSC, i zamiany układu klawiatury, dodania polskich fontów).

Atari 1040STe (TOS 1.62/2.06 UK, 4MB RAM), Atari 1040STfm (TOS 1.04 UK, 1MB RAM, BLiTTER, Gotek FF)
Digital Data Deicke HD64 (Megafile 60), SF314, UltraSatan, Gotek HxC, NetUSBee
Atari 65XE (64kB), Atari 800XL (64kB), Sinclair SPECTRUM+ (48kB), TIMEX Computer 2048 (48kB)

29

Odp: c't IDE

Wgraj swoją czcionkę/czcionki (6x6, 8x8, 8x16) do katalogu "PATCHFLD.104\FONTS"
W pliku "104_REL.FIL" zmień ".FONTS = 0 " na ".FONTS = 1 " oraz zmień nazwy fontów *.ABS na Twoje.

.FONTS = 1          ;1: Fonts einbinden, 0: Keine Fonts einbinden

_IF .FONTS
 -FONTS\                  ;Dsetpath("FONTS\")
 28A78 6X6_FONT.ABS       ;1152 Bytes (da 6x6 Font!)
 29154 8X8_FONT.ABS       ;2048 Bytes (8x8 Font)
 29954 NEU.ABS            ;4096 Bytes (8x16 Font)
 -..                      ;Dsetpath("..") (Ein Verzeichnis zurck)
_ENDIF

Pliki RSC znajdziesz w katalogu "PATCHFLD.104\RSC". Możesz je edytować w Interface. Potem w pliku "104_REL.FIL" zmień ".RSC = 0" na ".RSC = 1"

.RSC = 1            ;1: RSC-Patch einbinden, 0: RSC-Patch nicht einbinden

Po tych zmianach wykonaj krok nr 4. "wykonaj TOSPATCH.TTP z komendą:   104_REL.FIL."

Lynx II / Jaguar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
SDrive / PAK68/3 / Lynx Multi Card / LDW Super 2000 / XCA12 / SkunkBoard / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
http://260ste.appspot.com

30

Odp: c't IDE

Ok, dzięki - czyli jak rozumiem nie da się wyciągnąć RSC z obrazu TOSu i na nim pracować, tylko trzeba używać tego RSC z TOSpatcha, a ono niestety jest niemieckie hmm. Swoją drogą - dlaczego nikt się nie "dzieli" tłumaczeniami, bo wiem że istnieją. Niektóre są tragiczne ale inne całkiem niezłe - ale oceniam tylko po zrzutach ekranu, bo pobrać obrazu znikąd nie można.

Atari 1040STe (TOS 1.62/2.06 UK, 4MB RAM), Atari 1040STfm (TOS 1.04 UK, 1MB RAM, BLiTTER, Gotek FF)
Digital Data Deicke HD64 (Megafile 60), SF314, UltraSatan, Gotek HxC, NetUSBee
Atari 65XE (64kB), Atari 800XL (64kB), Sinclair SPECTRUM+ (48kB), TIMEX Computer 2048 (48kB)

31

Odp: c't IDE

Tutaj znajdziesz pełne źródła wszystkich oficjalnych wersji językowych TOS TOS 2.06/2.08/3.06
Znajdziesz tam też pliki RSC.
http://www.tho-otto.de/download/tos306de.tar.bz2

Grzegorz kiedyś zrobił tłumaczenie TOS na polski, ale teraz tego tam nie widzę:
http://atari.net.pl/po-polsku/

Ostatnio edytowany przez Cyprian (2019-02-17 23:25:42)

Lynx II / Jaguar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
SDrive / PAK68/3 / Lynx Multi Card / LDW Super 2000 / XCA12 / SkunkBoard / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
http://260ste.appspot.com

32

Odp: c't IDE

Jak zrobić bootowalny dysk z c't IDE z TOS-em 2.06 w "krótkim" 520ST bez flopa?

Nie wstaje mi ten TOS, mam 4 bomby, wyczytałem, że to normalne zachowanie TOS-a 2.06 jak nie ma fizycznie podpiętego flopa.
Myślałem jednak, że nie musi być flopa i że jak zrobię bootowalny dysk, to będzie startował i flopa można już odpuścić.

Jest tak: po pierwsze nie mam flopa i nijak nie mam tego jak obejść, bo nie mam nawet kabla, żeby Goteka do krótkiego ST podpiąć, więc nie mam jak sprawdzić, czy flop załatwił by temat i TOS by wstał.

Zrobiłem sobie plik wielkości karty CF i pod Hatari z tymże TOS-em 2.06 podpiąłem ten plik jako obraz dysku IDE.
Odpaliłem najnowszego HDDrivera z dyskietki *.st, zobaczył dysk, sformatowałem go, utworzyłem trzy partycje, zainstalowałem HDDRIVER.SYS na tym dysku i pod emulatorem bootuje się z niego poprawnie.
Aha, przy tworzeniu partycji zaznaczyłem kompatybilność z Windows i z TOS 1.04 lub nowszymi (tam jest też opcja 1.06 lub nowszymi, czym to się różni?).
Następnie ten obraz dysku nagrałem na kartę CF (programem HDDRawCopy). I tutaj też jest wszystko dobrze, partycje są widoczne, są FAT16, pod Windowsem widać pierwszą partycję i jest ok.
W ST podpinam kartę i nic. Odpalam i mam ciągle 4 bomby, a dysk nie bootuje. Mignie tylko dioda od aktywności i nic więcej.
Ta sama karta CF pod EmuTOS-em na fizycznym sprzęcie bootuje normalnie i wszystkie trzy partycje są poprawnie widoczne.

Pytanie jest w sumie przede wszystkim takie, czy w ogóle TOS 2.06 wstanie bez fizycznie podpiętego flopa, czy musi go mieć pomimo bootującego dysku? Może musi byc jakiś patch, czy tam specjalna wersja TOS-u? A może coś jeszcze robię źle, lub nie zrobiłem czegoś a powinienem?

33

Odp: c't IDE

_tzok_ napisał/a:

Swoją drogą - dlaczego nikt się nie "dzieli" tłumaczeniami, bo wiem że istnieją.

Jak się dokopię do mojego to wrzucę na stronkę. Swoją drogą same RSC to nie wszystko, są teksty których tam nie znajdziesz, zmieniałem je bezpośrednio w HexEditor'ze np. "Koniec testu pamięci" itp.
U mnie na stronie jest plik polski.fil który wlaśnie zamienia tekst na polski tam, gdzie nie da się przez RSC, o ile mnie pamięć nie myli to także w oknach typu: 12 plików o rozmiarze xxxKB.

Mq napisał/a:

Jak zrobić bootowalny dysk z c't IDE z TOS-em 2.06 w "krótkim" 520ST bez flopa?

Problemem jest chyba właśnie opcja kompatybilności Windows/TOS oraz kwestia byte swap bez której dysk nie będzie bootowalny.
Jak chcesz mogę Ci podesłać obraz karty 64MB która wystartuje z c'tIDE lub np. pierwszej partycji zrobiony pod HDDriverem.

Było miło :) Do widzenia.

34

Odp: c't IDE

To podeślij jak możesz ten obraz do testu. Ostatecznie i tak chcę zrobić samemu wszystko, bo w tym cała zabawa i chcę się nauczyć więcej o ST, ale chętnie sprawdzę taki obraz, który u Ciebie się bootuje, bo jeśli u mnie zabootuje, to będę wiedział, że nie mam żadnych innych problemów ze sprzętem.
A jak to jest z tym brakiem flopa pod TOS 2.06? Nie przeszkadza jak jest dysk bootowalny?

35

Odp: c't IDE

Nie przeszkadza. Mam płyty 260 i 520ST krótkie, obie startują z dysku bez flopa.

Było miło :) Do widzenia.

36

Odp: c't IDE

A jak nie ma ani dysku ani flopa to są te 4 bomby zawsze?
U mnie jest tak, że pokazuje się logo Atari, potem testuje pamięć, potem jest ten czarny pasek, który się zmniejsza, i na koniec wyskakują 4 bomby. Gdzieś wyczytałem, że to normalne, ale chciałem się upewnić.
TOS mam od Ciebie, więc dobry, kości na milion procent dobre, bo na tych samych EmuTOS śmiga bez problemu.
Podeślij mi proszę jakiś obraz karty tak jak mówisz, może być 64MB, pustą kartę jak zobrazujesz i spakujesz zipem, to będzie malutki pliczek. Poproszę na maila.

37

Odp: c't IDE

Zależy od wersji TOS:
1.x startuje bez stacji dysków
2.x/3.x nie startują stacji dysków
4.x - nie pamiętam

Lynx II / Jaguar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
SDrive / PAK68/3 / Lynx Multi Card / LDW Super 2000 / XCA12 / SkunkBoard / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
http://260ste.appspot.com

38

Odp: c't IDE

_tzok_ napisał/a:

Swoją drogą - dlaczego...

Na razie do 2.06/3.06 (chyba są identyczne), na dole strony:
http://atari.wroclaw.pl/tos.html

Czy znajdę do 1.4 to nie wiem, gdyż swego czasu dysk mi padł i nie chciało mi się odtwarzać.

Ostatnio edytowany przez artik-wroc (2019-02-18 10:22:46)

Było miło :) Do widzenia.

39

Odp: c't IDE

@Mq, TOS 2.06 ma C'T wystarcza do prawidłowej pracy. Przetestowane na krótkim ST jak i na MegaST.

Do tego zdecydowałem się na zakup 1.04i od Putnika i bootowanie tez działa ładnie na C'T IDE. Ja jestem zadowolony bo działa wszystko.

@Mq pod HATARI to zrobisz. Zrób obraz karty CF, zamontuje w hatari. Programem od PP stwórz partycje, zainstaluj sterownik HDD od PP i masz gotowe partycje TOS/DOS

Potem przenosisz obraz na kartę CF i się bawisz

40

Odp: c't IDE

No dobra, mam driver Putnika też to mogę spróbować. W sumie nie pomyślałem, bo się uparłem na tego HDDrivera. Tylko że to też powinno działać tak samo, bo przecież u Artika działa, to u mnie też powinno.

41

Odp: c't IDE

dragmar napisał/a:

Do tego zdecydowałem się na zakup 1.04i od Putnika i bootowanie tez działa ładnie na C'T IDE. Ja jestem zadowolony bo działa wszystko

też przymierzam się do kupna. Jak wrażenia? Próbowałeś hibernacji?

Lynx II / Jaguar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
SDrive / PAK68/3 / Lynx Multi Card / LDW Super 2000 / XCA12 / SkunkBoard / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
http://260ste.appspot.com

42

Odp: c't IDE

Dla mnie rewelacja. Zapisuje każdy program i grę kiedy chce smile
Sterowniki HD ale tylko dla ACSI. działają super z ultrasatanem. Nie miałem na razie żadnych problemów z demami czy grami.

Sterowniki HDriver oraz PP dla IDE działają super do tego autoboot oraz możliwość pracy na partycjach =<1GB.

Działa to wszystko stabilnie.

Czekam na jego 2.14 (tos 1.04 z pulpitem 2.06). Zobaczymy jak to tam będzie wszystko wyglądać

PP napisał program do hibernacji, tu jego krótka instrukcja

State saves container file creator util

This is util specially for improved TOS versions 1.04i, 1.62i , 2.64, 2.66 - which
support statesaves function - with 10 save slots.

First thing is to ensure that partition on which want to create and use that file
has enough free space and that is not fragmented.

Free space needed is:  RAM size x 10 . So, for 512 KB it is 5 MB.
For 4 MB it is 40 MB (binary values) .

Run program and click CREATE FILE button. Select DIR and give filename.
Depending on file size and disk speed it may take few secs up to 1-2 minutes.

If all wenk OK, program will say 'Success' . And then state saves will work. But need first to reboot Atari to activate it.

   PP, Febr. 2019

Ostatnio edytowany przez dragmar (2019-02-18 14:08:15)

43

Odp: c't IDE

Odwołuję chwilowo alarm, Artik nie musisz mi już nic wysyłać.
Powalczyliśmy trochę z Dragmarem i okazuje się, że jego obraz przygotowany na jego Atari działa również u mnie bez problemu.
Tak że "jestem w domu" i wszystko mi teraz już ruszyło tak jak powinno.

Zrobię jeszcze więcej testów, jak coś istotnego sprawdzę/wychwycę, to na pewno opiszę.

Postaram się zgłębić jeszcze temat tych niedziałających obrazów, ale najprawdopodobniej jest coś nie tak z obrazami zapisywanymi przez Hatari. Wszystkie drivery i wszystkie TOS-y działają mi poprawnie pod Hatari, natomiast obraz dysku z Hatari żaden nie działa w prawdziwym sprzęcie. Zgrywanie obrazów na karty CF na pewno jest ok, bo inne obrazy (nie z Hatari) działają dobrze w ten sposób zgrane.

44

Odp: c't IDE

Ja mam TOS od Petera w wersji 1.66i (ale dość okrojony i customizowany pod indywidualne zamówienie - praktycznie "goły" 1.62 z desktopem 2.06, bez drivera ACSI, jedynie z poprawką synchronizacji zegara z IKBD, pod kątem mojego "zegarka"). Jest ok, po poprawkach nie mam do niego zastrzeżeń.

Czy c't IDE ma potrzebną logikę do uruchomienia 2.06 na ST? Bo tak standardowo to 2.06 da się włożyć do STe wzwyż.

Atari 1040STe (TOS 1.62/2.06 UK, 4MB RAM), Atari 1040STfm (TOS 1.04 UK, 1MB RAM, BLiTTER, Gotek FF)
Digital Data Deicke HD64 (Megafile 60), SF314, UltraSatan, Gotek HxC, NetUSBee
Atari 65XE (64kB), Atari 800XL (64kB), Sinclair SPECTRUM+ (48kB), TIMEX Computer 2048 (48kB)

45

Odp: c't IDE

Aleś się wyrwał jak ten na F z konopii:-)
c't IDE to dwa urządzenia w jednym: interfejs IDE pod procesor i logika dla TOS-a 2.06. Tu się da tylko wsadzić TOS-a 2.06, ewentualnie EmuTOS-a. Można nie wkładać tutaj TOS-a i pozostać przy TOS-ie na płycie głównej. To jest w sensie, że do wyboru, albo wkładamy jedne kości, albo drugie.

46

Odp: c't IDE

Mq napisał/a:

Kompatybilność EmuTOS, to temat nie na ten wątek raczej, ale wszystkie gry, które udało mi się odpalić na 2.06, z tych które testowałem, zadziałały również na EmuTOS. Na stronie Putnika są gry dostosowane do pracy z HDD i wg opisów w tabelkach tam zamieszczonych prawie wszystkie są dostosowane równiez do TOS-u 2.06. Inna sprawa, że niektóre gry ze strony Putnika nie chcą mi się uruchamiać, ale zacząłem próbować pod emulatorem na różnych konfiguracjach sprzętowych i z różnymi TOS-ami i te gry, których nie mogę odpalić nie idą mi nawet pod TOS-em 1.04, więc nie wiem czy tam z tymi grami nie jest coś nie tak. Może ktoś ma wiedzę w tym temacie? Np. gra Ninja Mission, Prince of Persia, Secret of Monkey Island. Wszystkie te gry pokazują Putnikową planszę tytułową, po czym wychodzą do TOS-u z kolorami zmienionymi na fioletowy, niezależnie od wersji TOS-u i ilości pamięci RAM, zarówno na ST jak i na STE.
Natomiast gry, które działają poprawnie i to już przy 1MB na wszystkich TOS-ach, to np. D-Generation, Fire and Ice, IKPlus, Microprose Golf, Mouse Trap.

Odszczekuję. Wyżej wymienione gry na różnych TOS-ach testowałem pod emulatorem Hatari. Zarówno Hatari, jak i EmuTOS są produktami nienadającymi się do takich celów. Na żywym Atari pod TOS-em 2.06 chodzą mi już prawie wszystkie gry, a pod tym emulatorem bardzo dużo nie działa. Bardzo dużo nie działa też na EmuTOS-ie, więc produkty te zdecydowanie nie nadają się dla graczy.

47

Odp: c't IDE

Mq napisał/a:

próbowałem uruchomić jeden z jego projektów ACSI->CF, walczyłem z nim na maile przez pół roku (...) dzięki czemu w końcu sam ów interfejs sobie poskładałem, ulepszyłem i zadziałał:-)

Mógłbyś coś więcej o tym napisać, masz może projekt działającej płytki (bo sama płytka jest ponoć dużym problemem - na pająka działa, a na PCB nie chce). Jakieś wskazówki jak to uruchomić? Bo samo urządzenie bardzo mi się podoba.

Atari 1040STe (TOS 1.62/2.06 UK, 4MB RAM), Atari 1040STfm (TOS 1.04 UK, 1MB RAM, BLiTTER, Gotek FF)
Digital Data Deicke HD64 (Megafile 60), SF314, UltraSatan, Gotek HxC, NetUSBee
Atari 65XE (64kB), Atari 800XL (64kB), Sinclair SPECTRUM+ (48kB), TIMEX Computer 2048 (48kB)

48

Odp: c't IDE

Mam. Zrobiłem z tego gotowca włącznie z obudową itd. Nie publikowałem, bo tego nie da się zrobić tak, żeby działało każdemu w każdych warunkach. Idzie zbudować pojedynczy egzemplarz na użytek własny, ale jest to straszna walka:-). Wrzuć mi na PW swój adres mailowy, to wyślę Ci mailem informacje co i jak ze zdjęciami itd.

49

Odp: c't IDE

Mam czysto teoretyczne pytanie, czy gdyby podłączyć przełącznik do ROM2 oraz zostawić kości na płycie oraz w C't to była by możliwość wyboru TOS'u ?

50

Odp: c't IDE

Jeszcze tego nie próbowałem, ale na pewno trzeba by też powyłączać wszystkie pozostałe kości ROM-u na płycie, a więc oprócz ROM2 trzeba by też odłączać ROM1 i ROM0. Wydaje mi się, że gdyby naprzemiennie wtedy przełączać linie /CE od ROM-ów na płycie i ROM-ów w c't IDE, to powinno dać się przełączać w taki sposób TOS-y. Tylko trochę mi się nie podoba mieć TOS-y w 8 kościach:-) Najfajniej było by, gdyby się dało jakoś tak spreparować TOS 1.04, żeby się dało go wsadzić "zamiast" TOS-a 2.06. Czy jest jakaś taka możliwość? Czy ktoś kiedyś wsadził jakoś TOS 1.04 np. do STE? Gdyby tak, to analogicznie można by 1.04 w c't IDE wsadzić i to by rozwiązało wszystko elegancko.